[bug#77788] gnu: Add clipper2.
Commit Message
* a/gnu/packages/engineering.scm (clipper2): New variable.
Change-Id: Ie2ab2d8aa8aa1ef359320a1ad8be97194391974f
---
gnu/packages/engineering.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
Comments
>+ "Clipper2 is a major update of my original Clipper library that was first
>+released over 10 years ago. It's a multi-purpose polygon clipping library that
>+performs intersection, union, difference and XOR boolean operations on both
>+simple and complex polygons.")
I think you have to remove the use of the first person here. Maybe:
"Clipper2 is a multi-purpose polygon clipping library that
performs intersection, union, difference and XOR boolean
operations on both simple and complex polygons. It's a
major update of the Clipper C++/C# library."
And inverting the order of the sentences here makes for a
cleaner summary.
user guix
usertag 77788 reviewed looks-good
quit
@@ -3149,6 +3149,38 @@ (define-public python-lcapy
ontinuous-time and discret-time expressions.")
(license license:lgpl2.1+)))
+(define-public clipper2
+ (package
+ (name "clipper2")
+ (version "1.5.2") ;Update this to match the version you need
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AngusJohnson/Clipper2")
+ (commit (string-append "Clipper2_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1w8cmx712k45cb8gh9dakmbmybiwdx8c0b45mwpcldywx2lwxi2j"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list "-DCLIPPER2_UTILS=no" "-DCLIPPER2_EXAMPLES=no"
+ "-DCLIPPER2_USINGZ=no"
+ "-DUSE_EXTERNAL_GTEST=yes")
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-to-cpp
+ (lambda _
+ (chdir "CPP"))))))
+ (native-inputs (list googletest)) ;Only needed for tests
+ (synopsis "Polygon Clipping and Offsetting")
+ (description
+ "Clipper2 is a major update of my original Clipper library that was first
+released over 10 years ago. It's a multi-purpose polygon clipping library that
+performs intersection, union, difference and XOR boolean operations on both
+simple and complex polygons.")
+ (home-page "https://www.angusj.com/clipper2/Docs/Overview.htm")
+ (license license:boost1.0)))
+
(define-public openscad
(package
(name "openscad")