[bug#77788,v2] gnu: Add clipper2

Message ID 20250416234325.3765385-2-nomike@nomike.com
State New
Headers
Series [bug#77788,v2] gnu: Add clipper2 |

Commit Message

nomike April 16, 2025, 11:42 p.m. UTC
  * gnu/packages/engineering.scm (clipper2): New variable.

Change-Id: Ie09c5bb37e82db31c390eb7c6fb8bafcdf750e9a
---
Thanks for the hint. I missed that when copying the synopsis from the
original project.
I also removed some leftover comments I overlooked.
Here's a revised patch.

 gnu/packages/engineering.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
  

Comments

Gabriel Santos April 17, 2025, 2:03 a.m. UTC | #1
Em 16 de abril de 2025 20:42:35 BRT, nomike <nomike@nomike.com> escreveu:
>Thanks for the hint. I missed that when copying the synopsis from the
>original project.
>I also removed some leftover comments I overlooked.
>Here's a revised patch.

The synopsis and description LGTM. I'll try looking into the patch
with more detail and mark it as reviewed[1] tomorrow.

(I'm not a committer by the way, I'm just a guix-patches subscriber
in case you weren't aware)

[1] <https://guix.gnu.org/manual/devel/en/guix.html#Reviewing-the-Work-of-Others>
  

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index f37b0e3844..6d5d10d71f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -3149,6 +3149,37 @@  (define-public python-lcapy
 ontinuous-time and discret-time expressions.")
     (license license:lgpl2.1+)))
 
+(define-public clipper2
+  (package
+    (name "clipper2")
+    (version "1.5.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/AngusJohnson/Clipper2")
+             (commit (string-append "Clipper2_" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1w8cmx712k45cb8gh9dakmbmybiwdx8c0b45mwpcldywx2lwxi2j"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags (list "-DCLIPPER2_UTILS=no" "-DCLIPPER2_EXAMPLES=no"
+                               "-DCLIPPER2_USINGZ=no"
+                               "-DUSE_EXTERNAL_GTEST=yes")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'chdir-to-cpp
+                    (lambda _
+                      (chdir "CPP"))))))
+    (native-inputs (list googletest))
+    (synopsis "Polygon Clipping and Offsetting")
+    (description "Clipper2 is a multi-purpose polygon clipping library that
+performs intersection, union, difference and XOR boolean
+operations on both simple and complex polygons.  It's a
+major update of the Clipper C++/C# library.")
+    (home-page "https://www.angusj.com/clipper2/Docs/Overview.htm")
+    (license license:boost1.0)))
+
 (define-public openscad
   (package
     (name "openscad")