[bug#77790] gnu: Add font-adobe-source-han-serif.
Commit Message
* gnu/packages/fonts.scm (font-adobe-source-han-serif): New variable.
Change-Id: I451b3fbde4c9f2cfe1c214f9d32ea871cda71568
---
gnu/packages/fonts.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
Comments
Hello,
thanks for the patch! I have dropped the GET parameter from the URL,
dropped "open source" from the synopsis and description (since
everything in Guix is open source, I thought it did not add much),
and copy-pasted some more sentences from the homepage without content
that was too much marketing related.
It is pushed now.
Andreas
@@ -794,6 +794,28 @@ (define-public font-terminus
for long periods of working with computers (8 or more hours per day).")
(license license:silofl1.1)))
+(define-public font-adobe-source-han-serif
+ (package
+ (name "font-adobe-source-han-serif")
+ (version "2.003")
+ (source
+ (origin
+ ;; SuperOTC (all variations in one file) is not in the repository.
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/adobe-fonts/source-han-serif/releases/download/"
+ version "R/01_SourceHanSerif.ttc.zip"))
+ (sha256
+ (base32 "0pvrgba8r3khliws3zqhcqqa1gbjqfakx9q4yrdf6jl9aymqkrkf"))))
+ (build-system font-build-system)
+ (home-page
+ "https://source.typekit.com/source-han-serif/?scid=social71226596")
+ (synopsis "Open source Pan-CJK typeface in OpenType/CFF format")
+ (description
+ "This package provides Source Han Serif, an open source Pan-CJK typeface
+available in OpenType/CFF format.")
+ (license license:silofl1.1)))
+
(define-public font-adobe-source-han-sans
(package
(name "font-adobe-source-han-sans")