[bug#77832] news: Add entry for the node-build-system API change.
Commit Message
* etc/news.scm: Add entry.
Change-Id: I11b33fef997764f661e03a4b527c7610c48940f0
---
etc/news.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
base-commit: 12a6dd40a7b88454cc8a8c930c22681fcee5b1ea
Comments
Thank you Jelle for writing the news and simplifying node-build-system.
Could you add this German news translation? Also:
* I changed @{modify-json} to @code{modify-json}.
* I adjusted the line breaks to the 80 characters per line limit.
* When translating, I omitted the words “Note that”. I believe they
could also be removed from the English version, but have not made that
change. Does not matter much either way.
(entry (commit "3e9e164154af6245389af5a1781473b36263ad20")
(title
(en "Incompatible changes in the @code{node-build-system}")
(de "Inkompatible Änderungen im @code{node-build-system}"))
(body
(en "The @code{node-build-system} has been modified to work with the
new @code{modify-json} API.
Note that if you used @code{delete-dependencies} or
@code{with-atomic-json-file-replacement} in your own packages previously, you
now have to wrap these in @code{modify-json}. For example:
@lisp
(modify-json (delete-dependencies '(\"tslint\")))
@end lisp
The @code{npm-binary} importer generates package expressions using the new
@code{modify-json} API.")
(de "Das Erstellungssystem @code{node-build-system} wurde verändert und
benutzt jetzt die neue @code{modify-json}-API.
Wenn Sie bisher @code{delete-dependencies} oder
@code{with-atomic-json-file-replacement} in Ihren eigenen Paketen benutzt haben,
müssen Sie diese jetzt mit @code{modify-json} umhüllen. Zum Beispiel:
@lisp
(modify-json (delete-dependencies '(\"tslint\")))
@end lisp
Der @code{npm-binary}-Importer verwendet die neue @code{modify-json}-API und
erzeugt damit Paketausdrücke.")))
Regards,
Florian
Jelle Licht <jlicht@fsfe.org> writes:
> * etc/news.scm: Add entry.
>
> Change-Id: I11b33fef997764f661e03a4b527c7610c48940f0
LGTM, thanks. :-)
Ludovic Courtès <ludo@gnu.org> writes:
> Jelle Licht <jlicht@fsfe.org> writes:
>
>> * etc/news.scm: Add entry.
>>
>> Change-Id: I11b33fef997764f661e03a4b527c7610c48940f0
>
> LGTM, thanks. :-)
Merged into master and pushed[*] including Florian's suggested edits as a4a7ff0319.
Thanks one and all!
- Jelle
[*]: After 10+ times of getting a 502 error
@@ -28,6 +28,7 @@
;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
;; Copyright © 2024 Sebastian Dümcke <code@sam-d.com>
;; Copyright © 2025 Roman Scherer <roman@burningswell.com>
+;; Copyright © 2025 Jelle Licht <jlicht@fsfe.org>
;;
;; Copying and distribution of this file, with or without modification, are
@@ -36,6 +37,23 @@
(channel-news
(version 0)
+ (entry (commit "3e9e164154af6245389af5a1781473b36263ad20")
+ (title
+ (en "Incompatible changes in the @code{node-build-system}"))
+ (body
+ (en "The @code{node-build-system} has been modified to work with the new
+@code{modify-json} API.
+
+Note that if you used @code{delete-dependencies} or
+@code{with-atomic-json-file-replacement} in your own packages previously, you now
+have to wrap these in @code{modify-json}. For example:
+
+@lisp
+(modify-json (delete-dependencies '(\"tslint\")))
+@end lisp
+
+The @code{npm-binary} importer generates package expressions using the new
+@{modify-json} API.")))
(entry (commit "0e51c6547ffdaf91777f7383da4a52a1a07b7286")
(title