[bug#77810,1/4] gnu: opencascade-occt: Fix new version detection

Message ID 20250415011509.2138157-1-nomike@nomike.com
State New
Headers
Series [bug#77810,1/4] gnu: opencascade-occt: Fix new version detection |

Commit Message

nomike April 15, 2025, 1:15 a.m. UTC
  Change-Id: I079accd7da6d5e1ae7438bb0fd8428e9d8733b16
---
 gnu/packages/maths.scm | 4 ++++
 1 file changed, 4 insertions(+)
  

Comments

Andreas Enge April 15, 2025, 8:15 p.m. UTC | #1
Hello,

thanks for the patches around opencascade! Somehow you mixed up the
patch series; as explained in the manual, they need to be sent out in
two steps, otherwise, as seen here, every commit will open a bug of its
own:
   https://guix.gnu.org/manual/devel/en/html_node/Sending-a-Patch-Series.html#Multiple-Patches-1

I will reply separately on each issue.

I have applied this one, with a commit message adapted to our
conventions, and

Am Tue, Apr 15, 2025 at 03:15:06AM +0200 schrieb nomike:
> +        (release-tag-suffix . "")

this one removed; it looks meaningless, and detection of the new release
indeed also works without it.

Andreas
  

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 11a86216aa..8a1b963807 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3328,6 +3328,10 @@  (define-public opencascade-occt
   (package
     (name "opencascade-occt")
     (version "7.6.2")
+    (properties
+      '((release-tag-prefix . "^V")
+        (release-tag-suffix . "")
+        (release-tag-version-delimiter . "_")))
     (source
       (origin
         (method git-fetch)