[bug#77584,v2,4/4] gnu: greaseweazle-host-tools: Update to 1.22.

Message ID 20250406182736.31806-5-ian@retrospec.tv
State New
Headers
Series gnu: greaseweazle-host-tools: Update to 1.22. |

Commit Message

Ian Eure April 6, 2025, 6:27 p.m. UTC
  * gnu/packages/disk.scm (greaseweazle-host-tools): Update to 1.22.
[native-inputs]: Add python-setuptools and python-wheel.
[native-inputs]: Reformat.

Change-Id: Ib9fbfe0c130a1caf71a857ab8ee4e34f89f54697
---
 gnu/packages/disk.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
  

Comments

Andreas Enge April 14, 2025, 8:25 a.m. UTC | #1
Hello Ian,

this issue appears to be stuck on QA, but in fact a ganeti substitute is
already available.

I have pushed on your behalf and hope you do not mind, and am closing
this issue.

Andreas
  
Ian Eure April 14, 2025, 2:30 p.m. UTC | #2
Hi Andreas,

Andreas Enge <andreas@enge.fr> writes:

> Hello Ian,
>
> this issue appears to be stuck on QA, but in fact a ganeti 
> substitute is
> already available.

Ah, bummer, I guess QA is back to not processing much again.


> I have pushed on your behalf and hope you do not mind, and am 
> closing
> this issue.

I don’t mind at all, thank you very much!

  -- Ian
  
Andreas Enge April 14, 2025, 2:55 p.m. UTC | #3
Am Mon, Apr 14, 2025 at 07:30:27AM -0700 schrieb Ian Eure:
> Ah, bummer, I guess QA is back to not processing much again.

No, on the contrary, it processes a lot, the list of green badges is
growing! Here there was some kind of problem that the result had not been
registered, although everything was okay.

Andreas
  

Patch

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 3a1b0c0118..8363b21d18 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -56,6 +56,7 @@  (define-module (gnu packages disk)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages build-tools)
   #:use-module (gnu packages c)
+  #:use-module (gnu packages certs)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
@@ -718,7 +719,7 @@  (define-public idle3-tools
 (define-public greaseweazle-host-tools
   (package
     (name "greaseweazle-host-tools")
-    (version "1.12")
+    (version "1.22")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -727,7 +728,7 @@  (define-public greaseweazle-host-tools
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1lpvjlf2xg4ccwik8npiihi0lgw9dx5h12pp4ry343gkz4pwgk9x"))))
+                "1ji5sq9jf0p44982zkb5dj2d3mrpy675k0mkyg3r17q5syz0wbia"))))
     (build-system python-build-system)
     (arguments
      (list
@@ -740,7 +741,11 @@  (define-public greaseweazle-host-tools
             (lambda _
               (install-file "scripts/49-greaseweazle.rules"
                             (string-append #$output "/lib/udev/rules.d/")))))))
-    (native-inputs (list python-setuptools-scm))
+    (native-inputs
+     (list
+      python-setuptools
+      python-setuptools-scm
+      python-wheel))
     (propagated-inputs
      (list python-bitarray python-crcmod python-pyserial python-requests))
     (synopsis "Tools for accessing a floppy drive at the raw flux level")