[bug#77663,1/3] gnu: Add python-configshell-fb.
Commit Message
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Comments
Hi,
Thank you for the patch.
Some review points as the patch does not look nice for me ;-)
--8<---------------cut here---------------start------------->8---
+ (snippet #~(begin
+ (use-modules (guix build utils))
+ (delete-file "setup.py")
+ (delete-file-recursively "configshell_fb")
+ (rename-file "configshell" "configshell_fb")))
--8<---------------cut here---------------end--------------->8---
May you explain the reason behind this snippet?
--8<---------------cut here---------------start------------->8---
+ (arguments (list #:tests? #f))
+ (build-system pyproject-build-system)
--8<---------------cut here---------------end--------------->8---
Please follow example for some other packages in the module e.g.
build-system comes first then arguments, then inputs etc.
Why no tests?
--8<---------------cut here---------------start------------->8---
+ (propagated-inputs (list python-pyparsing))
+ (native-inputs (list python-wheel python-setuptools python-hatch-vcs python-hatchling))
--8<---------------cut here---------------end--------------->8---
Please apply list stile and sort alphabetically, some nice touch.
--8<---------------cut here---------------start------------->8---
+ (synopsis "A framework to implement simple but nice CLIs.")
--8<---------------cut here---------------end--------------->8---
No article in the begining (check with "guix lint") and no "." in the
end.
--8<---------------cut here---------------start------------->8---
+ (description
+ "This package provides a framework to implement simple but nice CLIs.")
--8<---------------cut here---------------end--------------->8---
"simple but nice" sound like a selling point but having n+ similar
packages available in Buix it's not clear, please try to extract info from
README or describe functionality more precise.
--
Oleg
@@ -16849,6 +16849,31 @@ (define-public python-cram
output.")
(license license:gpl2+)))
+(define-public python-configshell-fb
+ (package
+ (name "python-configshell-fb")
+ (version "1.1.30")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "configshell-fb" version))
+ (snippet #~(begin
+ (use-modules (guix build utils))
+ (delete-file "setup.py")
+ (delete-file-recursively "configshell_fb")
+ (rename-file "configshell" "configshell_fb")))
+ (sha256
+ (base32 "1zkhf62qsfcbxwzlc62r6qx37wwyscppc469rlm45zy9lzmbgxj1"))))
+ (arguments (list #:tests? #f))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-pyparsing))
+ (native-inputs (list python-wheel python-setuptools python-hatch-vcs python-hatchling))
+ (home-page "https://github.com/open-iscsi/configshell-fb")
+ (synopsis "A framework to implement simple but nice CLIs.")
+ (description
+ "This package provides a framework to implement simple but nice CLIs.")
+ (license license:asl2.0)))
+
(define-public python-crccheck
(package
(name "python-crccheck")