[bug#77185,v6] gnu: Add emacs-bqn-mode.
Commit Message
From: Lee Thompson <lee.p.thomp@gmail.com>
* gnu/packages/emacs-xyz.scm (emacs-bqn-mode): New variable.
Change-Id: Ibe9a32c4f8414dbc5d3bb350aa684a8f3e15c567
Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
V5 doesn't apply anymore.
gnu/packages/emacs-xyz.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)
base-commit: 90357c6090de8c6befec232996dbc7415112a081
--
2.49.0
Comments
Am Mittwoch, dem 09.04.2025 um 16:32 +0200 schrieb Cayetano Santos:
> From: Lee Thompson <lee.p.thomp@gmail.com>
>
> * gnu/packages/emacs-xyz.scm (emacs-bqn-mode): New variable.
>
> Change-Id: Ibe9a32c4f8414dbc5d3bb350aa684a8f3e15c567
> Signed-off-by: Cayetano Santos <csantosb@inventati.org>
> ---
Stole – ahem, *borrowed* – the Sign-off and pushed.
Thanks
@@ -489,6 +489,51 @@ (define-public emacs-bookmark-plus
reading the extensive documentation about BookmarkPlus on the Emacs Wiki.")
(license license:gpl3+)))
+(define-public emacs-bqn-mode
+ (package
+ (name "emacs-bqn-mode")
+ ;; upstream releases are tagged by date
+ (version "2024-09-10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/museoa/bqn-mode/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a4whlx8065c15nfyqy8176mwysnc13z4q7mmdfnf6skdnvi2pk6"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #f ;No tests found in source
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; `bqn-comint-bring' in `bqn-mode.el' uses the macro
+ ;; `thread-last', defined in `subr-x.el' but not autoloaded.
+ ;; `emacs-build-system' will happily byte-compile `bqn-mode.el'
+ ;; but interactively calling `bqn-comint-bring' will cause an
+ ;; error. An explicit call to `(require 'subr-x)' remedies the
+ ;; issue until it is fixed upstream.
+ (add-after 'unpack 'require-subr-x
+ (lambda _
+ (emacs-batch-edit-file "bqn-mode.el"
+ '(progn (goto-char (point-min))
+ (re-search-forward
+ "(require 'pulse)")
+ (forward-line)
+ (insert "(require 'subr-x)\n")
+ (basic-save-buffer))))))))
+ (propagated-inputs (list emacs-compat))
+ (synopsis "Emacs major mode for the BQN programming language")
+ (description
+ "This package provides a major mode for editing and executing BQN code.
+It can be used to interactively evaluate BQN code in buffer or can be used to
+launch BQN REPL sessions. For evaluating BQN code or spawning interpreters an
+executable implementation is required such as @code{cbqn} or @code{dbqn}.")
+ (home-page "https://github.com/museoa/bqn-mode/")
+ (license license:gpl3)))
+
(define-public emacs-cfrs
(package
(name "emacs-cfrs")