[bug#77694] gnu: emacs-emms: Activate tests and build info.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-emms): Activate tests and build info.
Change-Id: I232dd25a30156374d5e12f73948b26b6b274cc54
---
gnu/packages/emacs-xyz.scm | 18 +++++++++++++++++-
1 file changed, 17 insertions(+), 1 deletion(-)
base-commit: 2934de1447f87b361608ef3a2a756b8a5d2f42e6
Comments
Am Donnerstag, dem 10.04.2025 um 11:25 +0200 schrieb Cayetano Santos:
> * gnu/packages/emacs-xyz.scm (emacs-emms): Activate tests and build
> info.
>
> Change-Id: I232dd25a30156374d5e12f73948b26b6b274cc54
> ---
Pushed both this and 77692.
Cheers
@@ -4160,8 +4160,23 @@ (define-public emacs-emms
(name "emacs-emms")
(build-system emacs-build-system)
(arguments
- `(#:phases
+ `(#:tests? #t
+ #:test-command
+ (list "emacs" "-Q" "--batch"
+ "--eval=(cd \"test/\")"
+ "-l" "emms-tests.el"
+ "-l" "emms-info-native-tests.el"
+ "-l" "emms-info-native-ogg-tests.el"
+ "-l" "emms-info-native-mp3-tests.el"
+ "-l" "emms-info-native-flac-tests.el"
+ "-l" "emms-info-native-vorbis-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
(modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "make" "-C" "doc" "all")
+ (rename-file "doc/emms.info" "emms.info")))
(add-after 'unpack 'set-external-programs
;; Specify the absolute file names of the various programs
;; so that everything works out-of-the-box. (tinytag missing)
@@ -4205,6 +4220,7 @@ (define-public emacs-emms
(string-append "\"" vorbiscomment "\"")))
(substitute* "emms-info-exiftool.el"
(("\"exiftool\"") (string-append "\"" exiftool "\"")))))))))
+ (native-inputs (list texinfo))
(inputs
(list emacs-emms-print-metadata
alsa-utils