From c916c92ec10153ac549a9eaa8f9861739c5c2930 Mon Sep 17 00:00:00 2001
From: Zzull <bstrazzull@hotmail.fr>
Date: Mon, 13 May 2019 00:37:39 +0200
Subject: [PATCH] gnu: Add font-hermit
* gnu/packages/fonts.scm (font-hermit): New variable.
---
gnu/packages/fonts.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
@@ -1448,3 +1448,39 @@ formatting.")
"Public Sans is a strong, neutral, sans-serif typeface for text or
display based on Libre Franklin.")
(license license:silofl1.1)))
+
+(define-public font-hermit
+ (package
+ (name "font-hermit")
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://pcaro.es/d/otf-hermit-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09rmy3sbf1j1hr8zidighjgqc8kp0wsra115y27vrnlf10ml6jy0"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ ;; the tarball provided does not contain a directory
+ (lambda* (#:key source #:allow-other-keys)
+ (mkdir "source")
+ (invoke "tar" "xvf" source "-C" "source")
+ (chdir "source")
+ #t)))))
+ (home-page "https://pcaro.es/p/hermit/")
+ (synopsis "Monospace font")
+ (description
+ "Hermit is a monospace font designed to be clear, pragmatic and very
+readable. Its creation has been focused on programming. Every glyph was
+carefully planned and calculated, according to defined principles and rules.
+For this reason, Hermit is coherent and regular.
+
+Symbols stand out from common text. Dots and commas are easily seen, and
+operators are clear even when not surrounded by spaces. Similar characters
+have been designed to be very distinguishable from each other.")
+ (license license:silofl1.1)))
--
2.21.0