[bug#77547] gnu: libserialport: Update to 0.1.2.
Commit Message
* gnu/packages/electronics.scm (libserialport): Update to 0.1.2.
Change-Id: I977a2363cf0b1431d1c3247a9dd77c2e562097f5
---
gnu/packages/electronics.scm | 27 +++++++++++++++------------
1 file changed, 15 insertions(+), 12 deletions(-)
base-commit: d473abf0b40fe4bedf9423a6822d067a9a7826cf
Comments
Cayetano Santos <csantosb@inventati.org> writes:
> * gnu/packages/electronics.scm (libserialport): Update to 0.1.2.
Hi, the 'origin' and 'native-inputs' changes should also be mentioned in
the change log, ex:
[source]: Switch to git-fetch.
[native-inputs]: Add autoconf, automake, libtool.
> - (synopsis "Library for using serial ports")
> - (description "Libserialport is a minimal shared library written in C that is intended
> -to take care of the OS-specific details when writing software that uses serial ports.")
> + (synopsis "Cross-platform library for accessing serial ports")
> + (description
> + "libserialport is a minimal library written in C that is intended to
> +take care of the OS-specific details when writing software that uses serial ports.")
I think there is no need to change the synopsis and description here.
Could you send an update patch, thanks!
>dim. 06 avril 2025 at 14:40, 宋文武 <iyzsong@envs.net> wrote:
> I think there is no need to change the synopsis and description here.
These changes reflect the project’s author own readme first lines, which
I find is a nice principle, provided they comply with guix standards, as
in this case.
I remove the change.
> Could you send an update patch, thanks!
Done.
@@ -69,20 +69,23 @@ (define-module (gnu packages electronics)
(define-public libserialport
(package
(name "libserialport")
- (version "0.1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://sigrok.org/download/source/libserialport/libserialport-"
- version ".tar.gz"))
- (sha256
- (base32
- "17ajlwgvyyrap8z7f16zcs59pksvncwbmd3mzf98wj7zqgczjaja"))))
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://sigrok.org/libserialport")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dn10gmm3rwdsiw1psaczb9m52x6cfkfrbywm4f5y8fsmghh7dsy"))))
(build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
(home-page "https://sigrok.org/wiki/Libserialport")
- (synopsis "Library for using serial ports")
- (description "Libserialport is a minimal shared library written in C that is intended
-to take care of the OS-specific details when writing software that uses serial ports.")
+ (synopsis "Cross-platform library for accessing serial ports")
+ (description
+ "libserialport is a minimal library written in C that is intended to
+take care of the OS-specific details when writing software that uses serial ports.")
(license license:lgpl3+)))
(define-public libsigrokdecode