[bug#77127,1/1] gnu: Add emacs-ezf.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-ezf): New variable.
---
gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Comments
Am Mittwoch, dem 19.03.2025 um 23:11 +0000 schrieb Arun Isaac:
> * gnu/packages/emacs-xyz.scm (emacs-ezf): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
> 1 file changed, 36 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index f7459c3c32..02b394d779 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -2225,6 +2225,42 @@ (define-public emacs-fzf
> purpose finder.")
> (license license:gpl3+))))
>
> +(define-public emacs-ezf
> + (let ((commit "038513f7bd335981430f5d3386d533272567cefd")
> + (revision "0"))
> + (package
> + (name "emacs-ezf")
> + (version (git-version "0.1.0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mickeynp/ezf")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> +
> "0nrby8f3magyjwwyqk9bqyrgh04vlm8alajzng9x507n42pb7bn7"))))
> + (build-system emacs-build-system)
> + (arguments
> + (list #:tests? #t
You can drop #:tests? #t – it will become the default after emacs-team
is merged. (You still need it currently on master to run the tests,
but not afterwards)
> + #:test-command #~(list "emacs" "--batch"
> + "-l" "ezf.el" "-l" "ezf-test.el"
> + "-f" "ert-run-tests-batch-and-
> exit")
> + #:phases
> + #~(modify-phases %standard-phases
> + (add-after 'install 'install-script
> + (lambda _
> + (install-file "ezf"
> + (string-append #$output
> "/bin")))))))
> + (propagated-inputs
> + (list emacs-helm))
> + (home-page "https://github.com/mickeynp/ezf")
> + (synopsis "Emacs Fuzzy Finder")
> + (description "Emacs Fuzzy Finder is like fzf, but it leverages
> the power
> +of your Emacs instance to filter and select candidates. Use ezf as
> part of
> +piping and command substitutions to manually select and filter
> matches.")
> + (license license:gpl3+))))
> +
Cheers
Hi Liliana,
I have tested this package and it works. This patch is now ready to go.
> > + (arguments
> > + (list #:tests? #t
> You can drop #:tests? #t – it will become the default after emacs-team
> is merged. (You still need it currently on master to run the tests,
> but not afterwards)
Can we leave it on until then? I'd like to avoid not running tests in
that little window between now and the merge.
If that sounds good, I'll push this patch. Let me know.
Thanks for the review!
Regards,
Arun
Am Freitag, dem 04.04.2025 um 00:53 +0100 schrieb Arun Isaac:
>
> Hi Liliana,
>
> I have tested this package and it works. This patch is now ready to
> go.
>
> > > + (arguments
> > > + (list #:tests? #t
> > You can drop #:tests? #t – it will become the default after emacs-
> > team is merged. (You still need it currently on master to run the
> > tests, but not afterwards)
>
> Can we leave it on until then? I'd like to avoid not running tests in
> that little window between now and the merge.
>
> If that sounds good, I'll push this patch. Let me know.
It makes rebasing emacs-team less fun, but given that similar changes
were already pushed, go ahead.
Cheers
@@ -2225,6 +2225,42 @@ (define-public emacs-fzf
purpose finder.")
(license license:gpl3+))))
+(define-public emacs-ezf
+ (let ((commit "038513f7bd335981430f5d3386d533272567cefd")
+ (revision "0"))
+ (package
+ (name "emacs-ezf")
+ (version (git-version "0.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mickeynp/ezf")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nrby8f3magyjwwyqk9bqyrgh04vlm8alajzng9x507n42pb7bn7"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:tests? #t
+ #:test-command #~(list "emacs" "--batch"
+ "-l" "ezf.el" "-l" "ezf-test.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-script
+ (lambda _
+ (install-file "ezf"
+ (string-append #$output "/bin")))))))
+ (propagated-inputs
+ (list emacs-helm))
+ (home-page "https://github.com/mickeynp/ezf")
+ (synopsis "Emacs Fuzzy Finder")
+ (description "Emacs Fuzzy Finder is like fzf, but it leverages the power
+of your Emacs instance to filter and select candidates. Use ezf as part of
+piping and command substitutions to manually select and filter matches.")
+ (license license:gpl3+))))
+
(define-public emacs-pacfiles-mode
(package
(name "emacs-pacfiles-mode")