[bug#77391,v3,4/4] gnu: emacs-ellama: Enable tests; install info manual.

Message ID bf83dd22c5625737008ec8a045c2e5d7f1cdb281.1743606109.git.suhail@bayesians.ca
State New
Headers
Series gnu: emacs-ellama: Update to 1.8.0. |

Commit Message

Suhail Singh April 2, 2025, 2:42 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-ellama)[arguments]: Enable tests; skip
failing; install included pre-generated info manual.

Change-Id: I1b468c7b30ad35ae553d354ef63da2d4d1c056a7
---
 gnu/packages/emacs-xyz.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
  

Comments

Cayetano Santos April 2, 2025, 3:41 p.m. UTC | #1
>Wed 02 Apr 2025 at 10:42, "Suhail Singh" <suhailsingh247@gmail.com> wrote:

> +               (add-after 'install 'install-info
> +                 (lambda _
> +                   (install-file "ellama.info"
> +                                 (string-append #$output "/share/info")))))

Correct me if I’m wrong, but there is no need to install the info file,
the emacs builder takes care of this.
  
Suhail Singh April 2, 2025, 10 p.m. UTC | #2
Cayetano Santos <csantosb@inventati.org> writes:

> there is no need to install the info file, the emacs builder takes
> care of this.

Seems so, based on the code of the 'move-doc phase.  Thanks!
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5189ddd5d1..2c1e5801eb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5789,6 +5789,23 @@  (define-public emacs-ellama
               (sha256 (base32
                        "075bxdy2jzaq4nw2vpzlmxlq3mlvr0dklva5hbpzqm6pvwa2xz1k"))))
     (build-system emacs-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'disable-failing-tests
+                 (lambda _
+                   (substitute* (find-files "tests/" "\\.el$")
+                     (("\\(ert-deftest test-ellama-context-element-extract-info-node .*" all)
+                      (string-append all "(skip-unless nil)\n")))))
+               (add-after 'install 'install-info
+                 (lambda _
+                   (install-file "ellama.info"
+                                 (string-append #$output "/share/info")))))
+           #:tests? #t
+           #:test-command #~(list "emacs" "-Q" "--batch"
+                                  "-l" "ellama.el"
+                                  "-l" "tests/test-ellama.el"
+                                  "-f" "ert-run-tests-batch-and-exit")))
     (propagated-inputs (list emacs-compat emacs-llm emacs-plz emacs-transient))
     (home-page "https://github.com/s-kostyaev/ellama")
     (synopsis "Tool for interacting with LLMs")