[bug#76570,v3,1/6] gnu: Add libudfread.
Commit Message
* gnu/packages/cdrom.scm (libudfread): New variable.
Change-Id: Ifcd7d28474ec4b8061b2914d26d3f20f81f960ce
---
gnu/packages/cdrom.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
base-commit: 535efb3c9add7e32530aa0dced40b18b12b8ed95
Comments
Hi André,
Applied v3 of the patch series, thanks!
Ludo’.
Hi André,
Applied v3 of the patch series, thanks!
Ludo’.
@@ -17,6 +17,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Julian Flake <flake@uni-koblenz.de>
;;; Copyright © 2025 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2025 André Batista <nandre@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -970,6 +971,30 @@ (define-public libisofs
Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
(license gpl2+)))
+(define-public libudfread
+ (package
+ (name "libudfread")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.videolan.org/pub/videolan/libudfread/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "05c943ymw94nzjxf7v102916frqk7icgw4gb244wx23jn8cnz56m"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list automake autoconf libtool pkg-config))
+ (home-page "https://code.videolan.org/videolan/libudfread")
+ (synopsis "C library to read UDF file systems")
+ (description "@code{libudfread} is a C library for reading
+@acronym{UDF, Universal Disk Format} file systems. @acronym{UDF, Universal
+Disk Format} is a file system mostly used for DVDs and other optical media.
+It supports read-only media (DVD/CD-R) and rewritable media that wears out
+(DVD/CD-RW).")
+ (license lgpl2.1+)))
+
(define-public cdrkit-libre
(package
(name "cdrkit-libre")