[bug#77388,v1] gnu: stunnel: add missing perl dependency

Message ID 20250330155100.13241-1-david@aqwari.net
State New
Headers
Series [bug#77388,v1] gnu: stunnel: add missing perl dependency |

Commit Message

David Arroyo March 30, 2025, 3:51 p.m. UTC
  Without this dependency, $output/bin/stunnel3, which is a compatibility
script for programs to use stunnel 3.x command-line options, uses the
shebang #!/usr/bin/perl which doesn't exist.

* gnu/packages/web.scm (stunnel): add missing perl dependency

Change-Id: I68b21fbd2af96174d1fa8184f3ca398c67715453
---
 gnu/packages/web.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 77d5eb4c16984e430b377e0b5f1551fbda171ec6
  

Comments

Andreas Enge April 1, 2025, 10:57 p.m. UTC | #1
Pushed with an adapted commit message, thanks!

Andreas
  

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dd6e73e548..3923a9a5bd 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6774,7 +6774,7 @@  (define-public stunnel
          netcat
          procps
          python))
-  (inputs (list openssl))
+  (inputs (list openssl perl))
   (home-page "https://www.stunnel.org")
   (synopsis "TLS proxy for clients or servers")
   (description "Stunnel is a proxy designed to add TLS encryption