[bug#77148,8/9] gnu: edk2-tools: Update to 202502.

Message ID 24890fd7c8327bd2af4923b7adb09ab49458452d.1742546953.git.efraim@flashner.co.il
State New
Headers
Series New firmware and updates |

Commit Message

Efraim Flashner March 21, 2025, 8:53 a.m. UTC
  * gnu/packages/firmware.scm (edk2-tools): Update to 202502.
[arguments]: When building on armhf-linux add a phase to adjust the
compiler flags.

Change-Id: Ia0586cb748194e4ec0fa35c2a04cee64f1ad6521
---
 gnu/packages/firmware.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
  

Comments

Maxim Cournoyer March 22, 2025, 7:12 a.m. UTC | #1
Hi,

Efraim Flashner <efraim@flashner.co.il> writes:

> * gnu/packages/firmware.scm (edk2-tools): Update to 202502.
> [arguments]: When building on armhf-linux add a phase to adjust the
> compiler flags.

[...]

> +            #$@(if (target-arm32?)
> +                   #~((add-before 'configure 'fix-armhf-flags
> +                        (lambda _
> +                          (substitute* "BaseTools/Conf/tools_def.template"
> +                            (("(DEFINE GCC_ARM_CC_FLAGS.*)-mstack-protector-guard=global" _ gcc-arm)
> +                             (string-append gcc-arm "-fstack-protector-all"))))))
> +                   #~())

Is this problem known upstream?  If yes, it'd be nice to cross-reference
it here; otherwise, it'd be nice to report it to them (and
cross-reference the opened issue).
  
Efraim Flashner March 23, 2025, 3:22 p.m. UTC | #2
On Sat, Mar 22, 2025 at 04:12:59PM +0900, Maxim Cournoyer wrote:
> Hi,
> 
> Efraim Flashner <efraim@flashner.co.il> writes:
> 
> > * gnu/packages/firmware.scm (edk2-tools): Update to 202502.
> > [arguments]: When building on armhf-linux add a phase to adjust the
> > compiler flags.
> 
> [...]
> 
> > +            #$@(if (target-arm32?)
> > +                   #~((add-before 'configure 'fix-armhf-flags
> > +                        (lambda _
> > +                          (substitute* "BaseTools/Conf/tools_def.template"
> > +                            (("(DEFINE GCC_ARM_CC_FLAGS.*)-mstack-protector-guard=global" _ gcc-arm)
> > +                             (string-append gcc-arm "-fstack-protector-all"))))))
> > +                   #~())
> 
> Is this problem known upstream?  If yes, it'd be nice to cross-reference
> it here; otherwise, it'd be nice to report it to them (and
> cross-reference the opened issue).

I'll check, but it's probably based on our GCC version.  It only happens
for the armhf firmware when built on armhf.
  

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 0becefb3b08..fe2956fbfdf 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -947,7 +947,7 @@  (define-public slof-qemu
 (define-public edk2-tools
   (package
     (name "edk2-tools")
-    (version "202402")
+    (version "202502")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -958,7 +958,7 @@  (define-public edk2-tools
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0y7jfpijgi099znhzjklnsczn0k0vm1d1qznq9x2a2sa0glydsin"))))
+                "026h7hadzj1zflgf4qzdby3gmgcqh3m5rvn2yr92jjwn4z8c51la"))))
     (build-system gnu-build-system)
     (arguments
      (list #:make-flags
@@ -1047,6 +1047,13 @@  (define* (make-ovmf-firmware arch)
                           "riscv64-linux-gnu-")
                   (setenv (string-append #$toolchain "_LOONGARCH64_PREFIX")
                           "loongarch64-linux-gnu-"))))
+            #$@(if (target-arm32?)
+                   #~((add-before 'configure 'fix-armhf-flags
+                        (lambda _
+                          (substitute* "BaseTools/Conf/tools_def.template"
+                            (("(DEFINE GCC_ARM_CC_FLAGS.*)-mstack-protector-guard=global" _ gcc-arm)
+                             (string-append gcc-arm "-fstack-protector-all"))))))
+                   #~())
             (replace 'configure
               (lambda _
                 (let* ((cwd (getcwd))