[bug#77040,7/7] gnu: Add pay-respects.

Message ID 20250315184209.4188-7-gabrielsantosdesouza@disroot.org
State New
Headers
Series gnu: Add pay-respects. |

Commit Message

Gabriel Santos March 15, 2025, 6:41 p.m. UTC
  * gnu/packages/rust-apps.scm (pay-respects): New variable.

Change-Id: I836c33ff51985d4adbc4e71a349737555e717b34
---
 gnu/packages/rust-apps.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Comments

Gabriel Santos March 15, 2025, 8:39 p.m. UTC | #1
Please disconsider this patch for now, it is incomplete.

I forgot to remove my personal channel from the Guix I was using,
so the package was built successfully despite the missing packages.

I'll try building again, this time without my channel.

Sorry.

--
Gabriel Santos
  

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2f933d836c..f07db2af0c 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2024 normally_js <normally_js@posteo.net>
 ;;; Copyright © 2025 Divya Ranjan Pattanaik <divya@subvertising.org>
 ;;; Copyright © 2025 Andrew Wong <wongandj@icloud.com>
+;;; Copyright © 2025 Gabriel Santos <gabrielsantosdesouza@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4975,3 +4976,32 @@  (define-public podlet
      "This package generates Podman Quadlet files from a Podman command,
 compose file, or existing object.")
     (license license:mpl2.0)))
+
+(define-public pay-respects
+  (package
+    (name "pay-respects")
+    (version "0.6.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pay-respects" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0g3vsp6xyw5isr7l10mbljvdclh2s3cmpm7sqxf5a8ir9mfmvkz2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-colored" ,rust-colored-3)
+                       ("rust-inquire" ,rust-inquire-0.7)
+                       ("rust-pay-respects-parser" ,rust-pay-respects-parser-0.3)
+                       ("rust-pay-respects-utils" ,rust-pay-respects-utils-0.1)
+                       ("rust-regex-lite" ,rust-regex-lite-0.1)
+                       ("rust-rust-i18n" ,rust-rust-i18n-3)
+                       ("rust-sys-locale" ,rust-sys-locale-0.3))
+       #:install-source? #f))
+    (home-page "https://codeberg.org/iff/pay-respects")
+    (synopsis
+     "Correct mistyped console command by pressing f")
+    (description
+     "Pay Respects suggests fixes for wrong commands when the user
+inputs f after a mistake.")
+    (license license:agpl3+)))