[bug#76773] gnu: Add julia-polylog.

Message ID CH3PR02MB97462A0D8BD64C76EB1956C690CA2@CH3PR02MB9746.namprd02.prod.outlook.com
State New
Headers
Series [bug#76773] gnu: Add julia-polylog. |

Commit Message

King, Spencer via Guix-patches" via March 6, 2025, 6:18 a.m. UTC
  
  

Comments

Simon Tournier March 7, 2025, 5:37 p.m. UTC | #1
Hi Kyle,

Thanks.

On Thu, 06 Mar 2025 at 06:18, "King, Spencer via Guix-patches" via <guix-patches@gnu.org> wrote:

> +(define-public julia-polylog
> +  (package
> +    (name "julia-polylog")
> +    (version "2.5.1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/Expander/PolyLog.jl")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1rfmlh5rvgh84qvvachqgvy0ra5yym28vj09xlw9cq19bkyids64"))))
> +    (build-system julia-build-system)
> +    (home-page "https://github.com/Expander/PolyLog.jl")
> +    (synopsis "Implementation of polylogarithms in Julia")
> +    (description
> +     "This package implements real and complex polylogarithms,
> +including the real and complex dilogarithm and trilogarithm in Julia.")
> +    (license license:expat)))
> +

Ah, interesting, the ’check’ phase pass with Julia 1.8 but not with
Julia 1.9 because two dependencies seems missing [1]: julia-forwarddiff
and julia-chainrulestestutils.

Anyway, pushed to master as c8bde3c6725be4eb0743a153a3cf8de453d9e448.

Cheers,
simon


1: https://github.com/Expander/PolyLog.jl/blob/3c5f2bf771bc16d292b92f86e4740a5612a910b7/Project.toml#L20-L24
  

Patch

From 0ca9aa40a2dfb28c5855e8429690f0e5c61d23d8 Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Thu, 6 Mar 2025 00:12:36 -0600
Subject: [PATCH] gnu: Add julia-polylog.

* gnu/packages/julia-xyz.scm (julia-polylog): New variable.

Change-Id: I0ec8cec07552ef297fc1ecb086678fe9edfd051c
---
 gnu/packages/julia-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e1722c0fba..f875f345dd 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5218,6 +5218,27 @@  (define-public julia-plotutils
 plotting components.")
     (license license:expat)))
 
+(define-public julia-polylog
+  (package
+    (name "julia-polylog")
+    (version "2.5.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Expander/PolyLog.jl")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1rfmlh5rvgh84qvvachqgvy0ra5yym28vj09xlw9cq19bkyids64"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/Expander/PolyLog.jl")
+    (synopsis "Implementation of polylogarithms in Julia")
+    (description
+     "This package implements real and complex polylogarithms,
+including the real and complex dilogarithm and trilogarithm in Julia.")
+    (license license:expat)))
+
 (define-public julia-pooledarrays
   (package
     (name "julia-pooledarrays")

base-commit: 310adf4ce70cbb864859274fcc7842bd519bbddc
-- 
2.41.0