[bug#76412] gnu: emacs-elfeed-org: Update to latest.

Message ID 992242237f7755573d897ba14f05f131d589b302.1739963065.git.sarg@sarg.org.ru
State New
Headers
Series [bug#76412] gnu: emacs-elfeed-org: Update to latest. |

Commit Message

Sergey Trofimov Feb. 19, 2025, 11:04 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-elfeed-org): Update to latest.
[arguments]: Remove obsolete testing tweaks.
[propagated-inputs]: Remove unused dependencies.
---
 gnu/packages/emacs-xyz.scm | 32 +++++++-------------------------
 1 file changed, 7 insertions(+), 25 deletions(-)


base-commit: 27ae140024b6d05506cdf0d9fd5b91c25466f295
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: d09c064d38df73405d505b90d222dccfd7be09b9
  

Comments

Cayetano Santos Feb. 23, 2025, 10:10 a.m. UTC | #1
user guix
usertag 76412 + waiting-on-contributor
thanks

Guix QA review form submission:

Items marked as checked:

- Package builds
- Lint warnings
- Package tests
- List dependent packages build

Please review:

- commit message
- apply package style
- version is 20250104.0
- no need of emacs-org as propagated-input
  
Sergey Trofimov Feb. 23, 2025, 5:23 p.m. UTC | #2
Cayetano Santos <csantosb@inventati.org> writes:

> Please review:
>
> - commit message
> - apply package style
> - version is 20250104.0
> - no need of emacs-org as propagated-input

I've applied the suggested changes. However I'm not sure emacs-org
should be removed - it is listed in `Package-Requires`.
  
Cayetano Santos Feb. 23, 2025, 6:53 p.m. UTC | #3
>dim. 23 févr. 2025 at 18:23, Sergey Trofimov <sarg@sarg.org.ru> wrote:

> Cayetano Santos <csantosb@inventati.org> writes:
>
>> Please review:
>>
>> - commit message
>> - apply package style
>> - version is 20250104.0
>> - no need of emacs-org as propagated-input
>
> I've applied the suggested changes. However I'm not sure emacs-org
> should be removed - it is listed in `Package-Requires`.

Sure, but guix packages emacs-29.4, which already includes emacs-org.

Let’s committers decide about this point.
  
Ian Eure March 1, 2025, 6:16 p.m. UTC | #4
Cayetano Santos <csantosb@inventati.org> writes:

>>dim. 23 févr. 2025 at 18:23, Sergey Trofimov <sarg@sarg.org.ru> 
>>wrote:
>
>> Cayetano Santos <csantosb@inventati.org> writes:
>>
>>> Please review:
>>>
>>> - commit message
>>> - apply package style
>>> - version is 20250104.0
>>> - no need of emacs-org as propagated-input
>>
>> I've applied the suggested changes. However I'm not sure 
>> emacs-org
>> should be removed - it is listed in `Package-Requires`.
>
> Sure, but guix packages emacs-29.4, which already includes 
> emacs-org.
>
> Let’s committers decide about this point.

It definitely shouldn’t propagate emacs-org.  Org Mode has been 
bundled with Emacs for a long time, so this is unlikely to cause 
breakage due to a missing dependency; but mixing Org Mode versions 
can cause all sorts of problems.  Best to let the user decide 
whether they use bundled or external Org Mode.

  -- Ian
  
Ian Eure March 1, 2025, 6:21 p.m. UTC | #5
Hi Sergey,

Pushed as 352e037539 with some minor changelog editing.

Thanks,
  -- Ian
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5e48fab7e8..d888657cfa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15911,10 +15911,12 @@  (define-public emacs-elfeed-goodies
       (license license:gpl3+))))
 
 (define-public emacs-elfeed-org
-  (let ((commit "77b6bbf222487809813de260447d31c4c59902c9"))
+  (let ((commit "1197cf29f6604e572ec604874a8f50b58081176a")
+        (version "0.1")
+        (revision "2"))
     (package
       (name "emacs-elfeed-org")
-      (version (git-version "0.1" "1" commit))
+      (version (git-version version revision commit))
       (source
        (origin
          (method git-fetch)
@@ -15923,33 +15925,13 @@  (define-public emacs-elfeed-org
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0a2ibka82xq1dhy2z7rd2y9zhcj8rna8357881yz49wf55ccgm53"))))
+          (base32 "0giwnzlqk2s5hb6fs8a0l4dxcmn2fvkngpj1fayzwj0qnvds1kri"))))
       (build-system emacs-build-system)
       (arguments
        `(#:tests? #t
-         #:test-command '("ert-runner" "-L" "org-mode/lisp")
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'check 'chmod
-             (lambda _
-               (chmod "test/fixture-mark-feed-ignore.org" #o644)))
-           (add-before 'check 'xt-number-tests
-             (lambda _
-               ((lambda (file test-name)     ; variant of ert-number-tests
-                  (emacs-batch-edit-file file
-                    `(let ((i 0))
-                       (while (re-search-forward ,(string-append "xt-deftest "
-                                                                 test-name)
-                                                 nil t)
-                         (goto-char (match-beginning 0))
-                         (kill-region (match-beginning 0) (match-end 0))
-                         (insert (format "xt-deftest %s-%d" ,test-name i))
-                         (setq i (+ i 1)))
-                       (basic-save-buffer))))
-                "test/elfeed-org-test.el"
-                "rmh-elfeed-org-convert-headline-to-tagger-params"))))))
+         #:test-command '("ert-runner" "-L" "org-mode/lisp")))
       (propagated-inputs
-       (list emacs-elfeed emacs-org emacs-dash emacs-s))
+       (list emacs-elfeed emacs-org))
       (native-inputs
        (list emacs-ert-runner emacs-xtest))
       (home-page "https://github.com/remyhonig/elfeed-org")