[bug#76507] gnu: Add emacs-vhdl-ts-mode.

Message ID b06c77fa75f7a3b3de6149f6c0df8e9510924015.1740334152.git.csantosb@inventati.org
State New
Headers
Series [bug#76507] gnu: Add emacs-vhdl-ts-mode. |

Commit Message

Cayetano Santos Feb. 23, 2025, 6:09 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-vhdl-ts-mode): New variable.

Change-Id: I2bb6405e506c70a01bc7dd4d2d26d1430941129b
---

The testing framework uses downloads straight-el.

When author fixes this, I'll re-activate the tests. 

 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 0134b8c8d0679ec9b0494ac11a0b5636c2a43807
--
2.48.1
  

Comments

Ian Eure March 1, 2025, 5:38 p.m. UTC | #1
Hi Cayetano,

Pushed as 12c41b30bd.

Thanks,
  -- Ian
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e6bc0bba1d..75eea9847c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9049,6 +9049,32 @@  (define-public emacs-vhdl-mode
 with Emacs.")
     (license license:gpl3+)))
 
+(define-public emacs-vhdl-ts-mode
+  (package
+    (name "emacs-vhdl-ts-mode")
+    (version "0.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gmlarumbe/vhdl-ts-mode/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0vqq1819czzliicanv00hhv13zy9apvj4326pnj9n3iqx45q6a96"))))
+    (build-system emacs-build-system)
+    (arguments
+     ;; the testing framework, test-hdl, requires network
+     `(#:tests? #f
+       #:test-command '("make")))
+    (home-page "https://github.com/gmlarumbe/vhdl-ts-mode/")
+    (synopsis "VHDL Tree-sitter mode")
+    (description
+     "VHDL-ts-mode provides syntax highlighting, indentation, imenu,
+which-func, navigation and basic beautify and completion features to navigate
+and edit VHDL files.")
+    (license license:gpl3+)))
+
 (define-public emacs-mode-line-bell
   (package
     (name "emacs-mode-line-bell")