[bug#76605] gnu: Add emacs-flycheck-deno
Commit Message
Change-Id: If447a3bb0135f959c907465fe12f26624fd150eb
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
base-commit: 4f220482de742c9c03cf6378ab147026a330edd0
Comments
Hi Grigory,
Pushed as 0afe31a136.
Thanks,
-- Ian
@@ -9728,6 +9728,30 @@ (define-public emacs-flycheck-rust
the current Cargo project.")
(license license:gpl3+)))
+(define-public emacs-flycheck-deno
+ (package
+ (name "emacs-flycheck-deno")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/flycheck/flycheck-deno")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vvhzidnpzf25z5qn85zx7cpwaavd22vsds4q9y5mpmf8hi526l6"))))
+ (propagated-inputs
+ (list emacs-flycheck))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/flycheck/flycheck-deno")
+ (synopsis "Deno support for Flycheck")
+ (description
+ "This Flycheck extension configures Flycheck automatically for
+ the current Deno project.")
+ (license license:gpl3+)))
+
(define-public emacs-flycheck-package
(package
(name "emacs-flycheck-package")