[bug#76437,1/3] etc: teams: Add an electronics team.

Message ID af39accb0b3b04fe279b049ac9134c8bd5f20f9d.1740040076.git.csantosb@inventati.org
State New
Headers
Series Create electronics team, add Cayetano and Maxim |

Commit Message

Cayetano Santos Feb. 20, 2025, 9:22 a.m. UTC
  Change-Id: Ibc0b022a66be02ed98cd72da47357fc6e0af88e5
Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
 etc/teams.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)
  

Comments

Maxim Cournoyer Feb. 22, 2025, 2:58 p.m. UTC | #1
Cayetano Santos <csantosb@inventati.org> writes:

> Change-Id: Ibc0b022a66be02ed98cd72da47357fc6e0af88e5
> Signed-off-by: Cayetano Santos <csantosb@inventati.org>

Perhaps oddly in Guix, we use 'Signed-off-by' to means "signing off on
someone's else work", when committing other people work, instead of the
more usual way (as some kind of digital signature for our own work).

> ---
>  etc/teams.scm | 10 ++++++++++
>  1 file changed, 10 insertions(+)
>
> diff --git a/etc/teams.scm b/etc/teams.scm
> index 2aa8382225..81fb68fe3c 100755
> --- a/etc/teams.scm
> +++ b/etc/teams.scm
> @@ -13,6 +13,7 @@
>  ;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>  ;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
>  ;;; Copyright © 2025 Jelle Licht <jlicht@fsfe.org>
> +;;; Copyright © 2025 Cayetano Santos <csantosb@inventati.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -325,6 +326,15 @@ (define-team emacs
>                        "guix/scripts/import/elpa.scm"
>                        "tests/elpa.scm")))
>  
> +(define-team electronics
> +  (team 'electronics
> +        #:name "Electronics team"
> +        #:description "Electronics and hardware related packages."
> +        #:scope (list "gnu/packages/fpga.scm"
> +                      "gnu/packages/electronics.scm"
> +                      "gnu/package/libftdi.scm"

Added the missing 's' above and pushed.  Thank you!
  

Patch

diff --git a/etc/teams.scm b/etc/teams.scm
index 2aa8382225..81fb68fe3c 100755
--- a/etc/teams.scm
+++ b/etc/teams.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2025 Jelle Licht <jlicht@fsfe.org>
+;;; Copyright © 2025 Cayetano Santos <csantosb@inventati.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -325,6 +326,15 @@  (define-team emacs
                       "guix/scripts/import/elpa.scm"
                       "tests/elpa.scm")))
 
+(define-team electronics
+  (team 'electronics
+        #:name "Electronics team"
+        #:description "Electronics and hardware related packages."
+        #:scope (list "gnu/packages/fpga.scm"
+                      "gnu/packages/electronics.scm"
+                      "gnu/package/libftdi.scm"
+                      "gnu/packages/engineering.scm")))
+
 (define-team lisp
   (team 'lisp
         #:name "Lisp team"