[bug#75522,v1,2/3] gnu: Add zig-img.

Message ID 20250220190940.14643-3-ashvithshetty0010@zohomail.in
State New
Headers
Series Add beanbag |

Commit Message

Ashvith Shetty Feb. 20, 2025, 7:09 p.m. UTC
  From: Ashvith Shetty <ashvithshetty10@gmail.com>

zig-img is required by beanbag. However, there's no tags at the
moment, so we'll be using the commit mentioned in beanbag's repo.

* gnu/packages/zig-xyz.scm (zig-img): New variable.

Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
---
 gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
  

Comments

Hilton Chain Feb. 22, 2025, 4:46 a.m. UTC | #1
On Fri, 21 Feb 2025 03:09:11 +0800,
Ashvith Shetty wrote:
>
> From: Ashvith Shetty <ashvithshetty10@gmail.com>
>
> zig-img is required by beanbag. However, there's no tags at the
> moment, so we'll be using the commit mentioned in beanbag's repo.

Please reflect this information as a comment in package definition instead.

> * gnu/packages/zig-xyz.scm (zig-img): New variable.
>
> Change-Id: If66231806ffa50d0e6ec3091ab50f454db100f21
> ---
>  gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
> index 9b6bf09b56..e8fa59227d 100644
> --- a/gnu/packages/zig-xyz.scm
> +++ b/gnu/packages/zig-xyz.scm
> @@ -343,6 +343,28 @@ (define-public zig-clap
>  @end itemize")
>      (license license:expat)))
>
> +(define-public zig-img
> +  (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
> +        (revision "0"))
> +    (package
> +      (name "zig-img")
> +      (version (git-version "0.1.0" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/zigimg/zigimg")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
> +      (build-system zig-build-system)
> +    (home-page "https://github.com/zigimg/zigimg")
> +    (synopsis "Zig library for reading and writing different image formats")
> +    (description
> +     "This is a zig library for reading and writing different image formats.")

zig -> Zig

> +    (license license:expat))))
> +
>  (define-public zig-zls-0.10
>    (package
>      (name "zig-zls")
> --
> 2.48.1
>
  

Patch

diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 9b6bf09b56..e8fa59227d 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -343,6 +343,28 @@  (define-public zig-clap
 @end itemize")
     (license license:expat)))
 
+(define-public zig-img
+  (let ((commit "52f10dd3e3b1cd4614fe72a8a8f0eddc7700bc0a")
+        (revision "0"))
+    (package
+      (name "zig-img")
+      (version (git-version "0.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/zigimg/zigimg")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "187nh49rdv37arlvf056jiv58n4y87q2pm6qvznn75zrszjlvp0b"))))
+      (build-system zig-build-system)
+    (home-page "https://github.com/zigimg/zigimg")
+    (synopsis "Zig library for reading and writing different image formats")
+    (description
+     "This is a zig library for reading and writing different image formats.")
+    (license license:expat))))
+
 (define-public zig-zls-0.10
   (package
     (name "zig-zls")