[bug#76475] gnu: Add python-pygam.

Message ID 7d654d4783b694b7e72a8f5f53ae4b369a8b69ac.1740152190.git.navid.afkhami@mdc-berlin.de
State New
Headers
Series [bug#76475] gnu: Add python-pygam. |

Commit Message

Navid Afkhami Feb. 21, 2025, 3:36 p.m. UTC
  * gnu/packages/bioinformatics.scm (python-pygam): New variable.

Change-Id: I0bdd26546b17e3e0f96a32c6de9674d1731ba978
---
 gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)


base-commit: a036a455da1c91282ac2c6a7ca9757ee2e8ba107
  

Comments

Ricardo Wurmus Feb. 21, 2025, 4:43 p.m. UTC | #1
Applied, thank you!
  

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index af8756af09..3247d6dcc3 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3579,6 +3579,49 @@  (define-public python-pybio
 the managed genomes, STAR indexing and mapping and more.")
       (license license:gpl3+))))
 
+(define-public python-pygam
+  (package
+    (name "python-pygam")
+    (version "0.9.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dswah/pyGAM")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1bv404idswsm2ay3yziq1i2cbydq4f3vjav5s4i15bgd13k7zvim"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'build 'patch-pyproject
+            (lambda _
+              (substitute* "pyproject.toml"
+                ;; Change build backend
+                (("build-backend = .*") "build-backend = \"poetry.core.masonry.api\"\n")
+                ;; Modify version field
+                (("^version = \"0.0.0\"")
+                 (string-append "version = \"" #$version "\""))))))))
+    (propagated-inputs (list python-black
+                             python-flake8
+                             python-ipython
+                             python-numpy
+                             python-pandas
+                             python-poetry-core
+                             python-progressbar2
+                             python-scipy))
+    (native-inputs (list python-mock python-pytest python-pytest-cov))
+    (home-page "https://github.com/dswah/pyGAM")
+    (synopsis "Generalized additive models in Python")
+    (description
+     "This tool is for building Generalized Additive Models in Python.
+It emphasizes modularity and performance.The API will be immediately familiar
+to anyone with experience of scikit-learn or scipy.")
+    (license license:asl2.0)))
+
 (define-public python-pysnptools
   (package
     (name "python-pysnptools")