[bug#76272] gnu: Add emacs-syncthing.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-syncthing): New variable.
Change-Id: I357c59c35b818c9e1e74b191afa6b500d833845a
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Comments
Ian Eure <ian@retrospec.tv> skribis:
> * gnu/packages/emacs-xyz.scm (emacs-syncthing): New variable.
>
> Change-Id: I357c59c35b818c9e1e74b191afa6b500d833845a
LGTM! :-)
@@ -845,6 +845,27 @@ (define-public emacs-geiser-chez
"This package adds support for using Chez Scheme in Emacs with Geiser.")
(license license:bsd-3)))
+(define-public emacs-syncthing
+ (package
+ (name "emacs-syncthing")
+ (version "3.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KeyWeeUsr/emacs-syncthing.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1q755rcmlmpz9zb1i3ic3a3svyqwavncnfzmx0bsg6229qg06d0l"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/KeyWeeUsr/emacs-syncthing")
+ (synopsis "Emacs client for Syncthing")
+ (description
+ "Emacs-Syncthing is a client for the Syncthing file synchronization tool
+which provides an Emacs interface to replace the built-in web UI.")
+ (license license:gpl3+)))
+
(define-public emacs-vc-hgcmd
(package
(name "emacs-vc-hgcmd")