[bug#76272] gnu: Add emacs-syncthing.

Message ID 20250213204421.6057-1-ian@retrospec.tv
State New
Headers
Series [bug#76272] gnu: Add emacs-syncthing. |

Commit Message

Ian Eure Feb. 13, 2025, 8:44 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-syncthing): New variable.

Change-Id: I357c59c35b818c9e1e74b191afa6b500d833845a
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Comments

Ludovic Courtès Feb. 21, 2025, 2:21 p.m. UTC | #1
Ian Eure <ian@retrospec.tv> skribis:

> * gnu/packages/emacs-xyz.scm (emacs-syncthing): New variable.
>
> Change-Id: I357c59c35b818c9e1e74b191afa6b500d833845a

LGTM! :-)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 40e207bf0a..64aa9e636e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -845,6 +845,27 @@  (define-public emacs-geiser-chez
      "This package adds support for using Chez Scheme in Emacs with Geiser.")
     (license license:bsd-3)))
 
+(define-public emacs-syncthing
+  (package
+    (name "emacs-syncthing")
+    (version "3.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/KeyWeeUsr/emacs-syncthing.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1q755rcmlmpz9zb1i3ic3a3svyqwavncnfzmx0bsg6229qg06d0l"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/KeyWeeUsr/emacs-syncthing")
+    (synopsis "Emacs client for Syncthing")
+    (description
+     "Emacs-Syncthing is a client for the Syncthing file synchronization tool
+which provides an Emacs interface to replace the built-in web UI.")
+    (license license:gpl3+)))
+
 (define-public emacs-vc-hgcmd
   (package
     (name "emacs-vc-hgcmd")