[bug#76363] gnu: Add python-pytooling.
Commit Message
* gnu/packages/python-xyz.scm (python-pytooling): New variable.
Change-Id: Id045f071b6c531d4afff4322d1a544589f214d50
---
gnu/packages/python-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
base-commit: 651f8765b657e35baf85ac74a1f6b09ff71691cb
--
2.48.1
Comments
Cayetano Santos <csantosb@inventati.org> skribis:
> * gnu/packages/python-xyz.scm (python-pytooling): New variable.
>
> Change-Id: Id045f071b6c531d4afff4322d1a544589f214d50
[...]
> + (arguments
> + `(#:tests? #f))
As usual, could you either run the test suite or add a comment
explaining why it is skipped? (Which should be a last resort.)
Ludo’.
>jeu. 20 févr. 2025 at 11:29, Ludovic Courtès <ludovic.courtes@inria.fr> wrote:
> As usual, could you either run the test suite or add a comment
> explaining why it is skipped? (Which should be a last resort.)
Done. More recent versions of python-mypy and python-lxml are required
for running the tests. As soon as we have these, I’ll reactivate the tests.
C.
@@ -2584,6 +2584,30 @@ (define-public python-pytoolconfig
configuration file.")
(license license:lgpl3+)))
+(define-public python-pytooling
+ (package
+ (name "python-pytooling")
+ (version "8.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pyTooling/pyTooling/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07mca75d2zd6xl0isf0vrcblsc2niyqi7941dgjpiafnsgiygfzf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://pytooling.github.io/pyTooling/")
+ (synopsis "Miscellaneous python tools")
+ (description
+ "@code{pyTooling} is a collection of arbitrary useful classes,
+decorators, meta-classes and exceptions.")
+ (license license:asl2.0)))
+
(define-public python-colorlog
(package
(name "python-colorlog")