[bug#75683] gnu: Add emacs-discourse-mode.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-discourse-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Comments
Hello,
Yuval Langer <yuval.langer@gmail.com> writes:
> * gnu/packages/emacs-xyz.scm (emacs-discourse-mode): New variable.
Thank you.
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://codeberg.org/glenneth/discourse-mode")
> + (commit "v0.2.4")))
Please use (string-append "v" version) here.
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0j2f0vclj6zrmk1hxyrrhkcpk74vqvq42g9wjqrjw827yjh2wm65"))))
> + (build-system emacs-build-system)
> + (propagated-inputs (list emacs-compat
> + emacs-markdown-mode
> + emacs-request))
> + (home-page "https://codeberg.org/glenneth/discourse-mode")
> + (synopsis "Emacs package for interacting with Discourse forums")
> + (description "Browse categories, view topics, read posts, and
> +participate in discussions on Discourse, directly from Emacs.")
Description is expected to contain "complete" sentences. Here,
I suggest, unimaginatively:
This package lets you browse…
There are some tests in the repo. Could you try running them during
build? Or maybe they require internet access. I didn’t check.
Regards,
On Tue, Feb 18, 2025 at 7:42 PM Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
> Hello,
>
> Yuval Langer <yuval.langer@gmail.com> writes:
>
> > * gnu/packages/emacs-xyz.scm (emacs-discourse-mode): New variable.
>
> Thank you.
>
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://codeberg.org/glenneth/discourse-mode")
> > + (commit "v0.2.4")))
>
> Please use (string-append "v" version) here.
Done. (pending submission)
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32 "0j2f0vclj6zrmk1hxyrrhkcpk74vqvq42g9wjqrjw827yjh2wm65"))))
> > + (build-system emacs-build-system)
> > + (propagated-inputs (list emacs-compat
> > + emacs-markdown-mode
> > + emacs-request))
> > + (home-page "https://codeberg.org/glenneth/discourse-mode")
> > + (synopsis "Emacs package for interacting with Discourse forums")
> > + (description "Browse categories, view topics, read posts, and
> > +participate in discussions on Discourse, directly from Emacs.")
>
> Description is expected to contain "complete" sentences. Here,
> I suggest, unimaginatively:
>
> This package lets you browse…
Done.
> There are some tests in the repo. Could you try running them during
> build? Or maybe they require internet access. I didn’t check.
There are no up-to-date tests I can run. The author said he will
update them in a future version.
I will now submit my latest version of the package definition.
> Regards,
> --
> Nicolas Goaziou
Thank you,
Yuval Langer.
@@ -1564,6 +1564,29 @@ do manually if you wanted to keep the buffers of a project neatly isolated in
separate, named tab groups.")
(license license:gpl3+))))
+(define-public emacs-discourse-mode
+ (package
+ (name "emacs-discourse-mode")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/glenneth/discourse-mode")
+ (commit "v0.2.4")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j2f0vclj6zrmk1hxyrrhkcpk74vqvq42g9wjqrjw827yjh2wm65"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat
+ emacs-markdown-mode
+ emacs-request))
+ (home-page "https://codeberg.org/glenneth/discourse-mode")
+ (synopsis "Emacs package for interacting with Discourse forums")
+ (description "Browse categories, view topics, read posts, and
+participate in discussions on Discourse, directly from Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-disproject
(package
(name "emacs-disproject")