[bug#76354] gnu: Add python-imageio-freeimage.
Commit Message
* gnu/packages/python-xyz.scm (python-imageio-freeimage): New variable.
(python-imageio)[arguments]: Remove the freeimage substitution from the
'fix-source phase.
[inputs]: Remove freeimage.
Change-Id: I842998baea1568e1d9d1328e4387d14867bd3bb2
---
This patch is intended to clear transitive dependencies on openexr@2 and freeimage via imageio, which includes a freeimage plugin. Imageio has around ~100 packages to rebuild.
Freeimage last release was back in 2018, it is unknown to me whether it is still maintained and it may contain known and unpatched vulnerabilities (guix lint -c cve freeimage). OpenEXR 2 was also abandoned in favor of OpenEXR 3.
It seems that Debian has a patch to make freeimage work with OpenEXR 3. I may have a look at this later.
I noticed that imageio made a separate package for freeimage due to license concerns but I thought it would be a good fit for Guix for the reasons aforementioend.
Anyway, freeimage is slowly being deprecated in imageio: https://github.com/imageio/imageio/issues/892
gnu/packages/python-xyz.scm | 51 +++++++++++++++++++++++++++++++------
1 file changed, 43 insertions(+), 8 deletions(-)
base-commit: b4dc8eb4adff9d824ff7df704e134964b3b47396
Comments
Hi,
> (python-imageio)[arguments]: Remove the freeimage substitution from the
> 'fix-source phase.
--8<---------------cut here---------------start------------->8---
(add-after 'unpack 'fix-failing-tests
(lambda _
(substitute* "tests/test_core.py"
(("(core\\.load_lib)\\((\\[gllib\\], \\[\\])\\)"
all fun args)
(string-append "raises(ValueError, " fun ", " args ")")))
(delete-file "tests/test_freeimage.py"))))))
--8<---------------cut here---------------end--------------->8---
It looks the whole [arguments] block may be removed and skip test
logic applied in #:test-flags as the package uses python-pytest e.g.
"--ignore=tests/test_freeimage.py" or "-k not <test-name>".
--8<---------------cut here---------------start------------->8---
+ #:tests? #f ; tests need internet and are not distributed in PyPI
--8<---------------cut here---------------end--------------->8---
Maybe install from Git?
<https://github.com/imageio/imageio-freeimage/blob/master/tests/test_freeimage.py>
the only one tests file which does not require urllib or requrests.
--8<---------------cut here---------------start------------->8---
(symlink (search-input-file inputs "lib/libfreeimage.so")
--8<---------------cut here---------------end--------------->8---
Maybe swap to #$(this-package-input "<package>") instead?
---
Oleg
Hi,
> It looks the whole [arguments] block may be removed and skip test
> logic applied in #:test-flags as the package uses python-pytest e.g.
> "--ignore=tests/test_freeimage.py" or "-k not <test-name>".
Done, but I had to keep the TMPDIR substitution.
> Maybe install from Git?
> https://github.com/imageio/imageio-freeimage/blob/master/tests/test_freeimage.py
> the only one tests file which does not require urllib or requrests.
I tried, but most tests run imageio's downloader under the hood. IIRC
only 2 tests pass by default. Then I got to a point where some tests
pass in the build environment preserved by -K but still don't pass in
the build run. I eventually gave up on it as a few other tests were
still failing.
> Maybe swap to #$(this-package-input "<package>") instead?
Wasn't search-input-file preferred to not break package transformation?
I skipped this change in v3.
Hi,
> It looks the whole [arguments] block may be removed and skip test
> logic applied in #:test-flags as the package uses python-pytest e.g.
> "--ignore=tests/test_freeimage.py" or "-k not <test-name>".
Done, but I had to keep the TMPDIR substitution.
> Maybe install from Git?
> https://github.com/imageio/imageio-freeimage/blob/master/tests/test_freeimage.py
> the only one tests file which does not require urllib or requrests.
I tried, but most tests run imageio's downloader under the hood. IIRC
only 2 tests pass by default. Then I got to a point where some tests
pass in the build environment preserved by -K but still don't pass in
the build run. I eventually gave up on it as a few other tests were
still failing.
> Maybe swap to #$(this-package-input "<package>") instead?
Wasn't search-input-file preferred to not break package transformation?
I skipped this change in v3.
Vinicius
@@ -80,7 +80,7 @@
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020, 2021, 2022, 2023, 2024 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022, 2023, 2024, 2025 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
;;; Copyright © 2020 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
@@ -11892,6 +11892,48 @@ (define-public python-imageio-ffmpeg
from FFMPEG, reliably terminating the process when done.")
(license license:bsd-2)))
+(define-public python-imageio-freeimage
+ (package
+ (name "python-imageio-freeimage")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imageio_freeimage" version))
+ (sha256
+ (base32 "1la0iv3617m52dnidhhrdaz9dpnlfqs7b83550d3jkjavv30md72"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:tests? #f ; tests need internet and are not distributed in PyPI
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; imageio_freeimage expects a copy of the library in its source
+ ;; tree. Changing this would require hacky substitutions.
+ (add-after 'install 'freeimage-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((pylib (string-append #$output "/lib/python"
+ #$(version-major+minor
+ (package-version python))
+ "/site-packages"))
+ (iofi (string-append pylib "/imageio_freeimage")))
+ (mkdir-p (string-append iofi "/_lib"))
+ (symlink (search-input-file inputs "lib/libfreeimage.so")
+ (string-append iofi "/_lib/libfreeimage.so"))))))))
+ (native-inputs (list python-poetry-core python-requests python-setuptools
+ python-wheel))
+ (inputs (list freeimage))
+ (propagated-inputs (list python-imageio))
+ (home-page "https://github.com/imageio/imageio-freeimage")
+ (synopsis "Plugin for ImageIO that wraps the FreeImage library")
+ (description
+ "This package provides a plugin for @code{ImageIO} that wraps the
+@code{FreeImage} library.")
+ ;; As a derivative work of FreeImage, imageio_freeimage is licensed under
+ ;; GPLv2 or GPLv3, and the FreeImage Public License (FIPL).
+ ;; For more information, see the LICENSE file.
+ (license (list license:gplv2 license:gplv3 license:non-copyleft))))
+
(define-public python-imageio
(package
(name "python-imageio")
@@ -11911,12 +11953,6 @@ (define-public python-imageio
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-source
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* "imageio/plugins/_freeimage.py"
- (("os\\.getenv\\(\"IMAGEIO_FREEIMAGE_LIB\".*\\)" all)
- (string-append
- "(" all " or \""
- (search-input-file inputs "lib/libfreeimage.so")
- "\")")))
(substitute* "imageio/core/util.py"
(("\"/var/tmp\"")
"os.getenv(\"TMPDIR\", \"/tmp\")"))))
@@ -11927,7 +11963,6 @@ (define-public python-imageio
all fun args)
(string-append "raises(ValueError, " fun ", " args ")")))
(delete-file "tests/test_freeimage.py"))))))
- (inputs (list freeimage))
(propagated-inputs
(list python-imageio-ffmpeg python-numpy python-pillow python-tifffile))
(native-inputs