[bug#76375,gnome-team] gnu: gnome-shell: Fix substitutions for imports.

Message ID 8c3e3020bfac69625d020626babd798d4ba2cb89.1739826317.git.aurtzy@gmail.com
State New
Headers
Series [bug#76375,gnome-team] gnu: gnome-shell: Fix substitutions for imports. |

Commit Message

aurtzy Feb. 17, 2025, 9:15 p.m. UTC
  * gnu/packages/gnome.scm (gnome-shell)[arguments]<#:phases>: Update regexps
for substitutions in 'wrap-programs phase so search paths can be included
again.

Change-Id: Ie3582edbcb1e5712787c9292c449b161c7c9d869
---

Hi!

I noticed the Extensions app was no longer allowing me to view and set up
extensions while testing this branch, and discovered after some investigation
that the substitutions for imports were not applying due to changes in the
file.  Applying this patch fixed it for me.

I didn't pick this up before, but since it looked like Screencast had the same
issue, I applied the same change, which seems to also "re-enable" screen
recording with Screencast.

Cheers,

aurtzy

 gnu/packages/gnome.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 5e3e1b782b87d5bfe903f978490955cc20a70e5a
  

Comments

Maxim Cournoyer Feb. 18, 2025, 8:17 a.m. UTC | #1
aurtzy <aurtzy@gmail.com> writes:

> * gnu/packages/gnome.scm (gnome-shell)[arguments]<#:phases>: Update regexps
> for substitutions in 'wrap-programs phase so search paths can be included
> again.
>
> Change-Id: Ie3582edbcb1e5712787c9292c449b161c7c9d869
> ---
>
> Hi!
>
> I noticed the Extensions app was no longer allowing me to view and set up
> extensions while testing this branch, and discovered after some investigation
> that the substitutions for imports were not applying due to changes in the
> file.  Applying this patch fixed it for me.
>
> I didn't pick this up before, but since it looked like Screencast had the same
> issue, I applied the same change, which seems to also "re-enable" screen
> recording with Screencast.

Applied, thanks!
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c1896336cb..30c93c0ac3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9595,7 +9595,7 @@  (define-public gnome-shell
                    '("gnome-shell" "gnome-extensions" "gnome-extensions-app"))
                   (substitute* (string-append #$output "/share/gnome-shell/"
                                               "org.gnome.Shell.Extensions")
-                    (("imports\\.package\\.start" all)
+                    (("^import " all)
                      (string-append "'" gi-typelib-path "'.split(':').forEach("
                                     "path => imports.gi.GIRepository.Repository."
                                     "prepend_search_path(path));\n"
@@ -9604,7 +9604,7 @@  (define-public gnome-shell
                   ;; (i.e. as provided by home-pipewire-service-type)
                   (substitute* (string-append #$output "/share/gnome-shell/"
                                               "org.gnome.Shell.Screencast")
-                    (("imports\\.package\\.start" all)
+                    (("^import " all)
                      (string-append "'" gi-typelib-path "'.split(':').forEach("
                                     "path => imports.gi.GIRepository.Repository."
                                     "prepend_search_path(path));\n"