[bug#76351] gnu: Add emacs-nushell-mode.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-nushell-mode): New variable.
Change-Id: I216d8a9f7e7f89e379174a5d93020ff44c69d51f
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
base-commit: 6dde0ee30e5e030c2535514e9e39aa50518a5d20
prerequisite-patch-id: cc459efaf23197e58e97a6f0ad62058f71178746
prerequisite-patch-id: 492a9743436eae7679c7d9002f5b2d175eff9f1b
Comments
Hi Skylar,
Skylar Hill <stellarskylark@posteo.net> writes:
> * gnu/packages/emacs-xyz.scm (emacs-nushell-mode): New variable.
>
> Change-Id: I216d8a9f7e7f89e379174a5d93020ff44c69d51f
> ---
> gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm
> b/gnu/packages/emacs-xyz.scm
> index c006f1d912..d2bdd7b52d 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -35629,6 +35629,27 @@ (define-public emacs-ntlm
> implementation of Windows NT and LanManager compatible password
> encryption.")
> (license license:gpl3+)))
>
> +(define-public emacs-nushell-mode
> + (package
> + (name "emacs-nushell-mode")
> + (version "20231204.1233")
This needs to use `git-version'. While the package has no tagged
releases, nushell-mode.el has 0.1.0 declared as its version[1], so
using that is preferable to using a date.
You can look at other package in emacs-xyz.scm if you need an
example of how to version a package built off a Git snapshot;
emacs-0x0 is one that does.
Thanks,
-- Ian
[1]:
https://github.com/mrkkrp/nushell-mode/blob/c179c3cf573b2cc9421dc08bf47e2d619c7791ee/nushell-mode.el#L10
Hi Skylar,
Thanks for the fix, pushed as 2b94ea3880.
I have no idea how this caused a new bug to be opened & assigned
to me.
-- Ian
@@ -35629,6 +35629,27 @@ (define-public emacs-ntlm
implementation of Windows NT and LanManager compatible password encryption.")
(license license:gpl3+)))
+(define-public emacs-nushell-mode
+ (package
+ (name "emacs-nushell-mode")
+ (version "20231204.1233")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mrkkrp/nushell-mode.git")
+ (commit "c179c3cf573b2cc9421dc08bf47e2d619c7791ee")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08kx31h22szvmccswwmhyj615c9fqln45darlfkj7q84dmc2fd3n"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/mrkkrp/nushell-mode")
+ (synopsis "Major mode for Nushell scripts")
+ (description
+ "This package provides a very basic version of major mode for Nushell shell
+scripts.")
+ (license license:gpl3+)))
+
(define-public emacs-nadvice
(package
(name "emacs-nadvice")