[bug#76226] gnu: aerc: Update to 0.20.1.

Message ID 7c5918608ce28d577e5ad33cd37153c45680bc80.1739367829.git.tanguy@bioneland.org
State New
Headers
Series [bug#76226] gnu: aerc: Update to 0.20.1. |

Commit Message

Tanguy Le Carrour Feb. 12, 2025, 1:47 p.m. UTC
  * gnu/packages/mail.scm (aerc): Update to 0.20.1.
  [source]: Drop patch fixing a now solved problem with gpg-signed
  messages.
  [arguments]: Pass the build flag using an environment variable.
  [inputs]: Remove a comment. [native-inputs]: Use a newer version
  of go-git-sr-ht-rjarry-go-opt.

Change-Id: I71cc1330233e03996de914027f3d4d76b280acb4
---
Hi Guix!

First patch in a looooong time. Thanks in advance for your time
and patience!

Tanguy

 gnu/packages/mail.scm | 24 ++++++------------------
 1 file changed, 6 insertions(+), 18 deletions(-)


base-commit: b30669e15d2e8c3d1b74b32f77e2095682aab4ca
  

Comments

Sharlatan Hellseher Feb. 12, 2025, 10:01 p.m. UTC | #1
Hi,

Thank you for the patch.

I've adjusted commit message and pushed to master as
d0c2dc4ed1b4a8df8600e59a2c6906e375255ccc.

--
Oleg
  
Tanguy Le Carrour Feb. 13, 2025, 8:03 a.m. UTC | #2
Hi Oleg,


On Wed Feb 12, 2025 at 11:02 PM CET, GNU bug Tracking System wrote:
> Your bug report
> #76226: [PATCH] gnu: aerc: Update to 0.20.1.
> which was filed against the guix-patches package, has been closed.

Thanks!
  

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index dd8a7cd218f..1403f59c8be 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -5069,7 +5069,7 @@  (define-public smtpmail
 (define-public aerc
   (package
     (name "aerc")
-    (version "0.18.2")
+    (version "0.20.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -5078,26 +5078,14 @@  (define-public aerc
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0y34cv2vcwhr0vbd1ax2hv9rmv79dp9i02y2xqyr23krfb5bp197"))
-              (patches
-                (list
-                  ;; patch from upstream to fix encoding problem with sending
-                  ;; gpg-signed messages
-                  ;; see https://todo.sr.ht/~rjarry/aerc/79
-                  (origin
-                    (method url-fetch)
-                    (uri "https://git.sr.ht/~rjarry/aerc/commit/7346d20.patch")
-                    (file-name "aerc-fix-gpg-signed-message-encoding.patch")
-                    (sha256 (base32
-                              "14avr323sr9qipf9d7npqwrzq37i9946z9m6jdkzi8n9rs6zwzq9")))))))
+                "04412inhzj8vwybafqz6nw8wrsyf51zjv0881aacr6zc9bfcq510"))))
     (build-system go-build-system)
     (arguments
      (list #:import-path "git.sr.ht/~rjarry/aerc"
            ;; Installing the source is only necessary for Go libraries.
            #:install-source? #f
            #:build-flags
-           #~(list "-tags=notmuch"
-                   (string-append
+           #~(list (string-append
                     "-ldflags=-X main.Version=" #$version
                     " -X git.sr.ht/~rjarry/aerc/config.libexecDir="
                     #$output "/libexec/aerc"
@@ -5136,20 +5124,20 @@  (define-public aerc
                            (string-append "src/" import-path))))
                (replace 'install
                  (lambda* (#:key import-path build-flags #:allow-other-keys)
-                   (invoke "make" "CC=gcc" "install" "-C"
+                   (invoke "make" "CC=gcc" "GOFLAGS=-tags=notmuch" "install" "-C"
                            (string-append "src/" import-path)
                            (string-append "PREFIX=" #$output)))))))
     (inputs
      (append
       (list gnupg
-            notmuch ; Failing to build without it.
+            notmuch
             python
             python-vobject)
       (if (supported-package? zoxide)
           (list zoxide)
           '())))
     (native-inputs
-     (list go-git-sr-ht-rjarry-go-opt
+     (list go-git-sr-ht-rjarry-go-opt-v2
            go-git-sr-ht-rockorager-go-jmap
            go-git-sr-ht-rockorager-vaxis
            go-github-com-protonmail-go-crypto