[bug#53732] gnu: Add cl-css-lite.
Commit Message
* gnu/packages/lispy-xyz.scm (cl-css-lite): New variable.
---
gnu/packages/lisp-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Comments
Patch pushed as 9dbbf4ba48e5fa416261b3010567064d04d106c6 with a few
modifications.
Thanks.
@@ -20324,6 +20324,39 @@ (define-public cl-phos
(define-public ecl-phos
(sbcl-package->ecl-package sbcl-phos))
+(define-public sbcl-css-lite
+ (let ((commit "6ee4e6212ed56943d665df163d2a834b122e6273")
+ (revision "0"))
+ (package
+ (name "sbcl-css-lite")
+ (version "0.01")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/paddymul/css-lite")
+ (commit commit)))
+ (sha256
+ (base32 "1lyvw7hcy09k5qs6icky23s13psqxncyc73hdyiimb66p0jx6k0d"))
+ (file-name (git-file-name name commit))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:asd-files '("css-lite.asd")))
+ (home-page "https://github.com/paddymul/css-lite")
+ (synopsis "CSS grammar for Lisp")
+ (description
+"@code{cl-css-lite} is a library for generating CSS from an s-exp based
+syntax. When compiled with Parenscript loaded in the Lisp image, it
+also provides the same CSS generation facilities in Parenscript-generated
+JavaScript code.")
+ (license license:bsd-3))))
+
+(define-public cl-css-lite
+ (sbcl-package->cl-source-package sbcl-css-lite))
+
+(define-public ecl-css-lite
+ (sbcl-package->ecl-package sbcl-css-lite))
+
(define-public sbcl-nhooks
(package
(name "sbcl-nhooks")