[bug#75487] gnu: Add doom-runner.

Message ID bbca210fd0d1d60d4752dde4431c9f94ca5527fa.1736580280.git.wongandj@icloud.com
State New
Headers
Series [bug#75487] gnu: Add doom-runner. |

Commit Message

Andrew Wong Jan. 11, 2025, 7:24 a.m. UTC
  * gnu/packages/games.scm (doom-runner): New variable.

Change-Id: I986299789ab1c73b6a918226fdb33558355c0269
---
 gnu/packages/games.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)


base-commit: f15ca836e4686496f675308655c370c95e9f52b7
  

Comments

宋文武 Jan. 13, 2025, 12:24 a.m. UTC | #1
Andrew Wong <wongandj@icloud.com> writes:

> * gnu/packages/games.scm (doom-runner): New variable.

Pushed to master, thank you!

It seems my email can't reach icloud though.
  

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fb8018e271..ac6b0d314f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1517,6 +1517,58 @@  (define-public deal
                    license:gpl1+        ;ansidecl.h
                    license:bsd-3))))    ;random.c
 
+(define-public doom-runner
+  (package
+    (name "doom-runner")
+    (version "1.8.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Youda008/DoomRunner")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0rpywq95zy9w0wj1262x4rf84c52wg1rgf0by549qph6fybn34rn"))))
+    (build-system qt-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda _
+              (substitute* "DoomRunner.pro"
+                (("/usr")
+                 #$output))
+              (invoke "qmake" "DoomRunner.pro" "-spec" "linux-g++"
+                      "\"CONFIG+=release\"")))
+          (add-after 'install 'install-xdg
+            (lambda _
+              (with-directory-excursion "Install/XDG"
+                (install-file "DoomRunner.desktop"
+                              (string-append #$output
+                                             "/share/applications"))
+                (let ((install-icon
+                       (lambda (size)
+                         (install-file (simple-format
+                                        #f "DoomRunner.~sx~s.png"
+                                        size size)
+                                       (simple-format
+                                        #f "~a/share/icons/hicolor/~sx~s/apps"
+                                        #$output size size)))))
+                  (for-each install-icon
+                            '(16 24 32 48 64 128)))))))))
+    (home-page "https://github.com/Youda008/DoomRunner")
+    (synopsis "Launcher for Doom engine games")
+    (description
+     "Doom Runner is yet another launcher of common Doom source ports (like
+GZDoom, Zandronum, PrBoom, ...) with graphical user interface.  It is
+written in C++ and Qt, and it is designed around the idea of presets
+for various multi-file modifications to allow one-click switching
+between them and minimize any repetitive work.")
+    (license license:gpl3)))
+
 (define-public falltergeist
   (package
     (name "falltergeist")