[bug#54053] gnu: mercury: Use #:select instead of comment string.

Message ID 20220218061540.16927-1-jgart@dismail.de
State New
Headers
Series [bug#54053] gnu: mercury: Use #:select instead of comment string. |

Commit Message

jgart Feb. 18, 2022, 6:15 a.m. UTC
  * gnu/packages/mercury.scm (mercury)[define-module]: Use #:select instead of a
comment string for importing match-lambda.
---
 gnu/packages/mercury.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
  

Comments

Raghav Gururajan April 28, 2022, 2:41 a.m. UTC | #1
Pushed as f1d08be7af to master. Thanks for the patch.

Regards,
RG.
  

Patch

diff --git a/gnu/packages/mercury.scm b/gnu/packages/mercury.scm
index c87e65fdd1..1c7f5c5f55 100644
--- a/gnu/packages/mercury.scm
+++ b/gnu/packages/mercury.scm
@@ -31,7 +31,7 @@  (define-module (gnu packages mercury)
   #:use-module (gnu packages shells)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages pkg-config)
-  #:use-module (ice-9 match)) ; match-lambda
+  #:use-module ((ice-9 match) #:select (match-lambda)))
 
 ;; NOTE: Mercury uses a tightly coupled fork of BDWGC and
 ;; libatomic-ops. When updating the package, please check the GitHub