[bug#55126] gnu: Add emacs-org-roam-ui.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-org-roam-ui): New variable.
---
gnu/packages/emacs-xyz.scm | 34 +++++++++++++++++++++++++++++++---
1 file changed, 31 insertions(+), 3 deletions(-)
Comments
Hi Nocolas,
your patch also contains some reformatted text for emacs-org-generate:
please can you send an updated patch?
Thanks!
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:
> * gnu/packages/emacs-xyz.scm (emacs-org-roam-ui): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 34 +++++++++++++++++++++++++++++++---
> 1 file changed, 31 insertions(+), 3 deletions(-)
[...]
> (define-public emacs-org-generate
> (package
> (name "emacs-org-generate")
> @@ -29454,9 +29482,9 @@ (define-public emacs-org-generate
> ;; FIXME: Tests fail with "Wrong type argument: sequencep, :equal". It
> ;; seems to be an issue with Cort library.
> `(#:tests? #f
> - #:test-command '("emacs" "--batch" "--quick"
> - "--directory=." "--load=org-generate-tests.el"
> - "--funcall=cort-test-run")))
> + #:test-command '("emacs" "--batch" "--quick"
> + "--directory=." "--load=org-generate-tests.el"
> + "--funcall=cort-test-run")))
> (build-system emacs-build-system)
> (home-page "https://github.com/conao3/org-generate.el")
> (synopsis "Generate template files and folders from Org document")
> --
> 2.35.1
@@ -29433,6 +29433,34 @@ (define-public emacs-org-roam-bibtex
opening Org Ref's @code{cite:} links.")
(license license:gpl3+)))
+(define-public emacs-org-roam-ui
+ (let ((commit "9474a254390b1e42488a1801fed5826b32a8030b")
+ (revision "0"))
+ (package
+ (name "emacs-org-roam-ui")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/org-roam/org-roam-ui")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v54vxh95izch74wz2dl2dkdqicbvshra55l6qvd4xl5qmfhpjdc"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^out" %default-include)))
+ (propagated-inputs
+ (list emacs-org-roam emacs-websocket emacs-simple-httpd emacs-f))
+ (home-page "https://github.com/org-roam/org-roam-ui")
+ (synopsis "A graphical frontend for your org-roam Zettelkasten")
+ (description " Org-Roam-UI is a frontend for exploring and interacting
+with your @code{org-roam} notes. It is meant a successor of
+@code{org-roam-server} that extends functionality of org-roam with a Web app
+that runs side-by-side with Emacs.")
+ (license license:gpl3+))))
+
(define-public emacs-org-generate
(package
(name "emacs-org-generate")
@@ -29454,9 +29482,9 @@ (define-public emacs-org-generate
;; FIXME: Tests fail with "Wrong type argument: sequencep, :equal". It
;; seems to be an issue with Cort library.
`(#:tests? #f
- #:test-command '("emacs" "--batch" "--quick"
- "--directory=." "--load=org-generate-tests.el"
- "--funcall=cort-test-run")))
+ #:test-command '("emacs" "--batch" "--quick"
+ "--directory=." "--load=org-generate-tests.el"
+ "--funcall=cort-test-run")))
(build-system emacs-build-system)
(home-page "https://github.com/conao3/org-generate.el")
(synopsis "Generate template files and folders from Org document")