[bug#74505] Update freeciv to version 3.1.3
Commit Message
Comments
Hi!
I tried building and running an updated version.
It builds fine, but game has no sound.
> (inputs
> - (list curl cyrus-sasl gtk+ sdl-mixer zlib))
> + (list curl cyrus-sasl gtk+ sdl-mixer zlib sqlite))
As far as I understand - sdl-mixer version 1 support had been dropped in
version 3.1.0 [1]
I tried building with sdl2-mixer instead of sdl-mixer - that fixed the
sound issue.
Also, I think that dependency list should be sorted alphabetically (it
looks like it was previously).
[1] - https://web.archive.org/web/https://gna.org/patch/?6246
Hi Gustavo,
Thank you for the updated patch - it works great now (not a big fan of
freeciv, but at least game starts and sound works fine after selecting
sdl in sound options).
I don't have any comments about the changes in patch.
But I noticed some things to improve in commit messages and patch naming.
Looks like now it is not fully up to the Guix commit style practices.
Lets take a look on some package update commit message example [1]
Commit message first line should be in format:
> gnu: <package name>: Update to <version>
And then in following lines specific changes should be described:
> * gnu/packages/<file>.scm (<package>): Update to <version>
> [inputs]: <change in inputs description>
For broad and detailed commit logs standards you could check GNU Coding
Standards [2]. But examples are easier (:
Also, please send an updated version of the patch with the next
revision, so it would be easier for maintainers to distinct and apply
it.
To do this you could specify the revision 2 in git send-email. You could
find some instructions in documentation [3] at the end of the Single
Patches section.
Also, you could take a look on the mumi CLI tool, it makes working with
patches much easier [4].
Happy hacking!
[1] -
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=af28be202cb2b7fd0fc2e277467304f81c78ab74
[2] -
https://www.gnu.org/prep/standards/html_node/Change-Logs.html#Change-Logs
[3] -
https://guix.gnu.org/manual/devel/en/html_node/Sending-a-Patch-Series.html
[4] - https://guix.gnu.org/manual/devel/en/html_node/Debbugs-User-Interfaces.html#Command_002dLine-Interface
From 1e6f4b290500bbb84a9619478b43071a08a38815 Mon Sep 17 00:00:00 2001
Message-ID: <1e6f4b290500bbb84a9619478b43071a08a38815.1732399473.git.glab+guix@disroot.org>
From: Gustavo Laboreiro <glab+guix@disroot.org>
Date: Sat, 23 Nov 2024 20:05:09 +0000
Subject: [PATCH] Update freeciv to version 3.1.3
This is a trivial update to the package. A new dependency is
introduced (sqlite3).
Change-Id: If0c341b179d1704437f4bd74dd92d834a902c9b9
---
gnu/packages/games.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
@@ -85,6 +85,7 @@
;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
;;; Copyright © 2024 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2024 Ashvith Shetty <ashvithshetty10@gmail.com>
+;;; Copyright © 2024 Gustavo Laboreiro <glab+guix@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6721,7 +6722,7 @@ (define-public kobodeluxe
(define-public freeciv
(package
(name "freeciv")
- (version "3.0.8")
+ (version "3.1.3")
(source
(origin
(method url-fetch)
@@ -6733,10 +6734,10 @@ (define-public freeciv
(version-major+minor version) "/" version
"/freeciv-" version ".tar.xz")))
(sha256
- (base32 "1m3nwz0aad6p33zvmdldbw39riw2xqn99b6384bvx448c8ps6niv"))))
+ (base32 "0bvz5hqppj589w08bzrfzf5m6nwfwrzgg03lqb3p8hspjkx8c43l"))))
(build-system gnu-build-system)
(inputs
- (list curl cyrus-sasl gtk+ sdl-mixer zlib))
+ (list curl cyrus-sasl gtk+ sdl-mixer zlib sqlite))
(native-inputs
(list pkg-config))
(home-page "https://www.freeciv.org/")
base-commit: 285c78cb89cd0ef3775406eca9af9aa87de212a0
--
2.46.0