[bug#74506] gnu: fonts: Add font-dina
Commit Message
* gnu/packages/fonts.scm (font-dina): New variable.
---
Not only is this my first patch to Guix, but also my first patch sent
via email. Excuse me if I made any mistakes.
gnu/packages/fonts.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)
Comments
user guix
usertag 74506 + reviewed-looks-good
thanks
Guix QA review form submission:
Hi, thanks for your patch!
Everything works well, it is just missing a dot in the commit message,
and a double space between sentences in the description. I’m sending an
amended patch with these two changes.
Additionally, it is best to avoid adding your packages at the end of the
file to avoid merge conflicts, just put them where you feel like it or
near a related package.
Have a nice day,
Noé Lopez
Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package synopsis and descriptions
@@ -3874,3 +3874,22 @@ (define-public font-teko
full support for the conjuncts and ligatures required by languages
written with the Devanagari script.")
(license license:silofl1.1))))
+
+(define-public font-dina
+ (package
+ (name "font-dina")
+ (version "2.92")
+ (source (origin
+ (method url-fetch/zipbomb)
+ (uri "https://www.dcmembers.com/jibsen/download/61/?wpdmdl=61")
+ (file-name "Dina.zip")
+ (sha256
+ (base32
+ "1kq86lbxxgik82aywwhawmj80vsbz3hfhdyhicnlv9km7yjvnl8z"))))
+ (build-system font-build-system)
+ (home-page "https://www.dcmembers.com/jibsen/download/61/")
+ (synopsis "Dina programming font")
+ (description "Dina is a monospace bitmap font, primarily aimed at
+programmers. It is relatively compact to allow a lot of code on screen, while
+(hopefully) clear enough to remain readable even at high resolutions.")
+ (license license:expat)))