[bug#73884,v1,01/19] gnu: Add rust-windows-metadata-0.57

Message ID 20241019144935.11657-1-luca@lucamatei.com
State New
Headers
Series [bug#73884,v1,01/19] gnu: Add rust-windows-metadata-0.57 |

Commit Message

Luca Matei Pintilie Oct. 19, 2024, 2:49 p.m. UTC
  Change-Id: Ia6b72620d47db84c22de3a48d29592b8febc8b19
---
 gnu/packages/crates-windows.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
  

Comments

Efraim Flashner Oct. 21, 2024, 5:20 a.m. UTC | #1
I've only gotten patches 1-15 of the 19 patches sent, so I'll leave this
bug open for now. I've applied those 15 to the rust-team branch.
  
Luca Matei Pintilie Oct. 25, 2024, 9:52 p.m. UTC | #2
On Mon, Oct 21, 2024 at 08:20:26AM +0300, Efraim Flashner wrote:
>I've only gotten patches 1-15 of the 19 patches sent, so I'll leave this
>bug open for now. I've applied those 15 to the rust-team branch.

Hi, could you take a look again?
I had to send them split up like that due to the 20-email a day limit of
my provider, so I apologise for the trouble.

The last few patches show up on the web interface[1], so I hope it
should work as expected.

Let me know if I should send them again!

Thanks in advance

[1]: https://issues.guix.gnu.org/73884
  
Efraim Flashner Nov. 14, 2024, 6:40 a.m. UTC | #3
On Fri, Oct 25, 2024 at 11:52:53PM +0200, Luca Matei Pintilie wrote:
> On Mon, Oct 21, 2024 at 08:20:26AM +0300, Efraim Flashner wrote:
> > I've only gotten patches 1-15 of the 19 patches sent, so I'll leave this
> > bug open for now. I've applied those 15 to the rust-team branch.
> 
> Hi, could you take a look again?
> I had to send them split up like that due to the 20-email a day limit of
> my provider, so I apologise for the trouble.
> 
> The last few patches show up on the web interface[1], so I hope it
> should work as expected.
> 
> Let me know if I should send them again!
> 
> Thanks in advance
> 
> [1]: https://issues.guix.gnu.org/73884

Ok, I got the rest of the patches and applied them to the rust-team
branch. Closing this now.
  

Patch

diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 8d45d4f13c..922dcdb485 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -2235,6 +2235,23 @@  (define-public rust-windows-interface-0.39
        (sha256
         (base32 "00h56znmak3p8bh28y3s48m5zv6q7dn40vnvf3dzf0sz5rszrym2"))))))
 
+(define-public rust-windows-metadata-0.57
+  (package
+    (name "rust-windows-metadata")
+    (version "0.57.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "windows-metadata" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1z1xl76p0zjwsvyj16w6pbp2layhjqz13y34pid9x7avh9vd0243"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/microsoft/windows-rs")
+    (synopsis "Windows metadata reader")
+    (description "This package provides Windows metadata reader.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-windows-metadata-0.56
   (package
     (name "rust-windows-metadata")