[bug#54798,v2,2/4] gnu: awscli: Update to 1.22.90.
Commit Message
* gnu/packages/python-web.scm (awscli): Update to 1.22.90.
[inputs]: Replace python-botocore-for-awscli with python-botocore.
---
gnu/packages/python-web.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Comments
Felix Gruber schreef op zo 17-04-2022 om 20:04 [+0000]:
(string-append "cmdline = ['" (which "groff") "'"))))))))
While this was present in the original code, awscli-1.21.11 keeps a reference
to groff-1.22.4 and this appears to be a runtime thing, so I think
(which "groff") needs to be (search-input-file inputs "bin/groff") and groff
needs to be moved to 'inputs' instead of 'native-inputs' for cross-compilation
reasons. python-build-system doesn't support cross-compilation yet but
possibly someday it will ...
Greetings,
Maxime
@@ -2870,14 +2870,14 @@ (define-public awscli
(package
;; Note: updating awscli typically requires updating botocore as well.
(name "awscli")
- (version "1.21.11")
+ (version "1.22.90")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "0fkivwbx4nind5b7l4jhqm5bb9drgqsclcslrg4aggf9rcs4g4s0"))))
+ "0ky4ax4xh7s8w1l0hwc7w9ii8afvh9nib3kz09qhiqdinxzrlv54"))))
(build-system python-build-system)
(arguments
;; FIXME: The 'pypi' release does not contain tests.
@@ -2899,7 +2899,7 @@ (define-public awscli
(string-append "cmdline = ['" (which "groff") "'"))))))))
(inputs
(list python-colorama-for-awscli
- python-botocore-for-awscli
+ python-botocore
python-s3transfer
python-docutils-0.15
python-pyyaml