[bug#72322] gnu: Add go-github-com-anaskhan96-soup.

Message ID 20240727135906.4467-1-adam.quandour@gmail.com
State New
Headers
Series [bug#72322] gnu: Add go-github-com-anaskhan96-soup. |

Commit Message

Adam July 27, 2024, 1:59 p.m. UTC
  * gnu/packages/golang-web.scm (go-github-com-anaskhan96-soup): New variable.
---
 gnu/packages/golang-web.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Comments

Sharlatan Hellseher Aug. 26, 2024, 11:39 p.m. UTC | #1
Hi,

Thank you for the patch.

Pushed as fb2347f6d1 to master.

--
Oleg
  

Patch

diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index a9658cf..b474095 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -190,6 +190,33 @@  (define-public go-github-com-andybalholm-cascadia
 the parse trees produced by the html package.")
     (license license:bsd-2)))
 
+(define-public go-github-com-anaskhan96-soup
+  (package
+    (name "go-github-com-anaskhan96-soup")
+    (version "1.2.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/anaskhan96/soup")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s19119sy4zqf05sgpdymcbdaz5bg86n7xwgd2m1vvxjmp485k5p"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/anaskhan96/soup"))
+    (native-inputs
+     (list go-golang-org-x-net))
+    (inputs
+     ;; needed for the check phase
+     (list go-github-com-stretchr-testify))
+    (home-page "https://github.com/anaskhan96/soup")
+    (synopsis "Web Scraper in Go, similar to BeautifulSoup")
+    (description "Small web scraper package for Go, with its interface
+highly similar to that of BeautifulSoup.")
+    (license license:expat)))
+
 (define-public go-github-com-audriusbutkevicius-pfilter
   (package
     (name "go-github-com-audriusbutkevicius-pfilter")