[bug#34867] Add emacs-editorconfig

Message ID CAAc=MEzatG7=rbsNJXq__pUa5XVaSiv7yfVh1UK+OJw1-RKULQ@mail.gmail.com
State Accepted
Headers show
Series [bug#34867] Add emacs-editorconfig | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Brian Leung March 15, 2019, 2:39 a.m. UTC
See attached.

Comments

Oleg Pykhalov March 16, 2019, 11:02 a.m. UTC | #1
Hello Brian,

Pushed as a6718145265787e39bd0c703d22eb8846464fbec to master.

Thanks,
Oleg.

Patch

From 7c15fb1d0bd317ac14003b5c6252eecf3e0629a5 Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Fri, 15 Mar 2019 03:38:34 +0100
Subject: [PATCH] gnu: Add emacs-editorconfig.

---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9fdb00efb9..88b1d5642e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12469,6 +12469,30 @@  execute its commands and resize images.")
 backends, including the @command{wordnet} offline backend.")
       (license license:gpl3+))))
 
+(define-public emacs-editorconfig
+  (package
+    (name "emacs-editorconfig")
+    (version "0.7.14")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/editorconfig/editorconfig-emacs")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "19j2428ij7sqvrqs7rqg1mcnv9109y6drqba40dkv3vrkk5d2yia"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/editorconfig/editorconfig-emacs")
+    (synopsis "Define and maintain consistent coding styles between different
+editors and IDEs")
+    (description "The EditorConfig project consists of a file format for
+defining coding styles and a collection of text editor plugins that enable
+editors to read the file format and adhere to defined styles.  EditorConfig
+files are easily readable and they work nicely with version control systems.")
+    (license license:gpl3+)))
+
 (define-public emacs-all-the-icons
   (package
     (name "emacs-all-the-icons")
-- 
2.21.0