From c42ae1190500facb94ca1a2ddd253fabc93ca0aa Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Tue, 19 Feb 2019 22:01:06 -0600
Subject: [PATCH 2/3] gnu: Add emacs-lsp-mode.
* gnu/packages/emacs-xyz.scm (emacs-lsp-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
@@ -13158,3 +13158,31 @@ opposed to character-based).")
view of file listings sorted by size. Directory sizes are computed
recursively. The results are cached for speed.")
(license license:gpl3+)))
+
+(define-public emacs-lsp-mode
+ (package
+ (name "emacs-lsp-mode")
+ (version "6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-lsp/lsp-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v1mq6ixzlgiazj8fmg4xaqhsqn3l89iqy74yndhvzh2rdf0pbkl"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-spinner" ,emacs-spinner)))
+ (home-page "https://github.com/emacs-lsp/lsp-mode")
+ (synopsis "Emacs client and library for the Language Server Protocol")
+ (description "@code{LSP-mode} is a client and library implmentation for
+the Language Server Protocol. This mode aims to provide an IDE-like
+experience by providing optional integration with other popular Emacs packages
+like @code{company}, @code{flycheck}, and @code{projectile}.")
+ (license license:gpl3+)))
+
--
2.20.1