From 0589cf816ecabf2cf9b56d0733b8729ff451e397 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 21:39:30 -0600
Subject: [PATCH 23/24] gnu: Add r-magick.
* gnu/packages/cran.scm (r-magick): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
@@ -51,6 +51,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages haskell)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages javascript)
#:use-module (gnu packages lisp)
#:use-module (gnu packages machine-learning)
@@ -5929,6 +5930,39 @@ used within R markdown documents when rendering to HTML and to Word
documents.")
(license license:gpl3)))
+(define-public r-magick
+ (package
+ (name "r-magick")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "magick" version))
+ (sha256
+ (base32
+ "18y465325mhf48x2jn3jz9khwq1z2aj13wfbdkv8k3hln1sd572m"))))
+ (build-system r-build-system)
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-magrittr" ,r-magrittr)
+ ("r-rcpp" ,r-rcpp)
+ ("imagemagick" ,imagemagick)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (home-page
+ "https://github.com/ropensci/magick#readme")
+ (synopsis
+ "Advanced Graphics and Image-Processing in R")
+ (description
+ "Bindings to @code{ImageMagick}: the most comprehensive open-source image
+processing library available. Supports many common formats (png, jpeg,
+tiff, pdf, etc) and manipulations (rotate, scale, crop, trim, flip, blur,
+etc). All operations are vectorized via the Magick++ STL meaning they
+operate either on a single frame or a series of frames for working with
+layers, collages, or animation.")
+ (license license:expat)))
+
(define-public r-writexl
(package
(name "r-writexl")
--
2.20.1