Message ID | 20190228174435.14499-5-mail@ambrevar.xyz |
---|---|
State | Accepted |
Headers | show |
Series | [bug#34650,1/7] gnu: ruby-rack-protection: Update to 2.0.5. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Pierre Neidhardt <mail@ambrevar.xyz> writes: > * gnu/packages/ruby.scm (ruby-thin): New variable. > --- > gnu/packages/ruby.scm | 29 +++++++++++++++++++++++++++++ > 1 file changed, 29 insertions(+) > > diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm > index 78d113af7..9d3c4b246 100644 > --- a/gnu/packages/ruby.scm > +++ b/gnu/packages/ruby.scm > @@ -7754,3 +7754,32 @@ characteristics.") > minimal effort.") > (home-page "http://sinatrarb.com/") > (license license:expat))) > + > +(define-public ruby-thin > + (package > + (name "ruby-thin") > + (version "1.7.2") > + (source > + (origin > + (method url-fetch) > + (uri (rubygems-uri "thin" version)) > + (sha256 > + (base32 > + "0nagbf9pwy1vg09k6j4xqhbjjzrg5dwzvkn4ffvlj76fsn6vv61f")))) > + (build-system ruby-build-system) > + (arguments > + ;; TODO: Fix tests. > + `(#:tests? #f)) As with the other package, it would be good to put at least some information here about what the problem is. > + (propagated-inputs > + `(("ruby-daemons" ,ruby-daemons) > + ("ruby-eventmachine" ,ruby-eventmachine) > + ("ruby-rack" ,ruby-rack))) > + (synopsis "Thin and fast web server for Ruby") > + (description "Thin is a Ruby web server that glues together 3 Ruby libraries: > +@itemize > +@item the Mongrel parser, > +@item Event Machine, a network I/O library with high scalability, performance and stability > +@item Rack, a minimal interface between webservers and Ruby frameworks > +@end itemize\n") > + (home-page "http://code.macournoyer.com/thin/") > + (license license:ruby)))
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm index 78d113af7..9d3c4b246 100644 --- a/gnu/packages/ruby.scm +++ b/gnu/packages/ruby.scm @@ -7754,3 +7754,32 @@ characteristics.") minimal effort.") (home-page "http://sinatrarb.com/") (license license:expat))) + +(define-public ruby-thin + (package + (name "ruby-thin") + (version "1.7.2") + (source + (origin + (method url-fetch) + (uri (rubygems-uri "thin" version)) + (sha256 + (base32 + "0nagbf9pwy1vg09k6j4xqhbjjzrg5dwzvkn4ffvlj76fsn6vv61f")))) + (build-system ruby-build-system) + (arguments + ;; TODO: Fix tests. + `(#:tests? #f)) + (propagated-inputs + `(("ruby-daemons" ,ruby-daemons) + ("ruby-eventmachine" ,ruby-eventmachine) + ("ruby-rack" ,ruby-rack))) + (synopsis "Thin and fast web server for Ruby") + (description "Thin is a Ruby web server that glues together 3 Ruby libraries: +@itemize +@item the Mongrel parser, +@item Event Machine, a network I/O library with high scalability, performance and stability +@item Rack, a minimal interface between webservers and Ruby frameworks +@end itemize\n") + (home-page "http://code.macournoyer.com/thin/") + (license license:ruby)))