@@ -2,7 +2,7 @@
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016 Andy Patterson <ajpatter@uwaterloo.ca>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -21,10 +21,14 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages scanner)
+ #:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages libusb)
#:use-module (gnu packages pkg-config)
#:use-module (guix build-system gnu)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses)
#:prefix licence:)
#:use-module (guix packages)
@@ -132,3 +136,67 @@ package contains the library, but no drivers.")
proving access to any raster image scanner hardware (flatbed scanner,
hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The
package contains the library and drivers.")))
+
+(define-public xsane
+ (package
+ (name "xsane")
+ (version "0.999")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/sane-project/frontend/xsane.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08zvxj7i1s88ckrsqldmsrikc3g62a6p3s3i5b5x4krcfpi3vs50"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list (string-append "xsanedocdir=" (assoc-ref %outputs "out")
+ "/share/doc/" ,name "-" ,version))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-invalid-dereference
+ ;; Fix the following compilation error with libpng:
+ ;; xsane-save.c: In function ‘xsane_save_png’:
+ ;; xsane-save.c:4913:21: error: dereferencing pointer to
+ ;; incomplete type ‘png_struct {aka struct png_struct_def}’
+ ;; if (setjmp(png_ptr->jmpbuf))
+ ;; ^
+ (lambda _
+ (substitute* "src/xsane-save.c"
+ (("png_ptr->jmpbuf") "png_jmpbuf(png_ptr)"))
+ #t))
+ (add-after 'unpack 'use-sane-help-browser
+ (lambda _
+ (substitute* "src/xsane.h"
+ (("netscape") "xdg-open"))
+ #t))
+ (add-after 'install 'delete-empty-/sbin
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (rmdir (string-append out "/sbin"))
+ #t))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+-2)
+ ("lcms" ,lcms)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("sane-backends" ,sane-backends)))
+ (home-page "https://gitlab.com/sane-project/frontend/xsane")
+ (synopsis "Featureful graphical interface for document and image scanners")
+ (description
+ "XSane is a graphical interface for controlling a scanner and acquiring
+images from it. You can photocopy multi-page documents and save, fax, print,
+or e-mail your scanned images. It is highly configurable and exposes all
+device settings, letting you fine-tune the final result. It can also be used
+as a GIMP plugin to aquire images directly from a scanner.
+
+XSane is a front-end for SANE, which means that almost any existing scanner is
+supported: flatbed and hand-held scanners, video and still cameras, and frame
+grabbers.")
+ (license licence:gpl2+))) ; lib/snprintf.c is under the ‘Artistic’ licence