Message ID | f4d5449bfe86f3b1fcebd4650959101c2758ec84.1550437064.git.leo@famulari.name |
---|---|
State | Accepted |
Commit | fc681a18f52635e4bd1dbc9e962e57930f0c7ad3 |
Headers | show |
Series | [bug#34515,01/13] gnu: Add python-humanize. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Leo Famulari <leo@famulari.name> writes:
> * gnu/packages/python-crypto.scm (python-spake2): New variable.
LGTM!
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm index 29e0ee5951..6ca82cb061 100644 --- a/gnu/packages/python-crypto.scm +++ b/gnu/packages/python-crypto.scm @@ -1016,3 +1016,23 @@ relevant RFCs too.") (description "This package provides a Python implementation of the HMAC Key Derivation function (HKDF) defined in RFC 5869.") (license license:bsd-2))) + +(define-public python-spake2 + (package + (name "python-spake2") + (version "0.8") + (source + (origin + (method url-fetch) + (uri (pypi-uri "spake2" version)) + (sha256 + (base32 + "1x16r7lrbklvfzbacb66qv9iiih6liq1y612dqh2chgf555n2yn1")))) + (build-system python-build-system) + (propagated-inputs + `(("python-hkdf" ,python-hkdf))) + (home-page "https://github.com/warner/python-spake2") + (synopsis "SPAKE2 password-authenticated key exchange in Python") + (description "This package provides a Python implementation of the SPAKE2 +Password-Authenticated Key Exchange algorithm.") + (license license:expat)))