Message ID | 4579ae8b04a0c15d83ea3696ef58d2ce2377381b.1550437064.git.leo@famulari.name |
---|---|
State | Accepted |
Headers | show |
Series | [bug#34515,01/13] gnu: Add python-humanize. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Leo Famulari <leo@famulari.name> writes: > * gnu/packages/python-web.scm (python-treq): New variable. […] > + (description "This package provides an HTTP library inspired by > +@code{requests}} but written on top of @code{Twisted's} Agents. Should @code{…} be moved from “Twisted’s” to “Agents”? Otherwise looks good to me.
On Mon, Feb 18, 2019 at 09:08:31AM +0100, Ricardo Wurmus wrote: > > Leo Famulari <leo@famulari.name> writes: > > > * gnu/packages/python-web.scm (python-treq): New variable. > […] > > + (description "This package provides an HTTP library inspired by > > +@code{requests}} but written on top of @code{Twisted's} Agents. > > Should @code{…} be moved from “Twisted’s” to “Agents”? > > Otherwise looks good to me. Thanks, will do.
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm index 052331cc44..e54f09ddb4 100644 --- a/gnu/packages/python-web.scm +++ b/gnu/packages/python-web.scm @@ -2973,3 +2973,30 @@ ecosystem.") (description "This package provides a Python module to create immutable, and correct URLs for Python according to RFCs 3986 and 3987.") (license license:expat))) + +(define-public python-treq + (package + (name "python-treq") + (version "18.6.0") + (source + (origin + (method url-fetch) + (uri (pypi-uri "treq" version)) + (sha256 + (base32 + "0j4zwq9p1c9piv1vc66nxcv9s6hdinf90jwkbsm91k14npv9zq4i")))) + (build-system python-build-system) + (propagated-inputs + `(("python-attrs" ,python-attrs) + ("python-hyperlink" ,python-hyperlink) + ("python-idna" ,python-idna) + ("python-incremental" ,python-incremental) + ("python-requests" ,python-requests) + ("python-service-identity" ,python-service-identity) + ("python-twisted" ,python-twisted))) + (home-page "https://github.com/twisted/treq") + (synopsis "Requests-like API built on top of twisted.web's Agent") + (description "This package provides an HTTP library inspired by +@code{requests}} but written on top of @code{Twisted's} Agents. It offers a +high level API for making HTTP requests when using Twisted.") + (license license:expat)))