[bug#53852] gnu: Add emacs-volatile-highlights.
Commit Message
Comments
Hello,
Jai Vetrivelan <jaivetrivelan@gmail.com> writes:
> Subject: [PATCH] gnu: Add emacs-volatile-highlights.
Thank you.
> +(define-public emacs-volatile-highlights
> + (let ((commit "9a20091f0ce7fc0a6b3e641a6a46d5f3ac4d8392")
> + (revision "0"))
> + (package
> + (name "emacs-volatile-highlights")
> + (version (git-version "1.15" revision commit))
The commit used matches the version bump. Therefore you can drop
revision and `git-version', and add a comment explaining this.
> + (synopsis "Minor mode for visual feedback on editing operations")
Maybe: Emacs minor mode for visual…
> + (description "This package provides minor mode
> +@command{volatile-highlights-mode}, which brings visual feedback to some
> +operations by highlighting portions relating to the operations. All of
> +highlights made by this library will be removed when any new operation is
> +executed.")
I would start with:
Volatile Highlights minor mode brings visual feedback to…
Otherwise LGTM.
Could you send an updated patch?
From 6c814343186b154751b8391fe62cbef27bcd28e4 Mon Sep 17 00:00:00 2001
From: Jai Vetrivelan <jaivetrivelan@gmail.com>
Date: Mon, 7 Feb 2022 21:46:29 +0530
Subject: [PATCH] gnu: Add emacs-volatile-highlights.
* gnu/packages/emacs-xyz.scm (emacs-volatile-highlights): new variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -30340,6 +30340,31 @@ (define-public emacs-validate-html
Validator service and displays the results in a buffer in Compilation mode.")
(license license:gpl3+))))
+(define-public emacs-volatile-highlights
+ (let ((commit "9a20091f0ce7fc0a6b3e641a6a46d5f3ac4d8392")
+ (revision "0"))
+ (package
+ (name "emacs-volatile-highlights")
+ (version (git-version "1.15" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://github.com/k-talo/volatile-highlights.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256n
+ (base32
+ "1dsa6769lphyyv7yg92vkkpk395w52q4m7hdn8xy7s6lh5c6a955"))))
+ (build-system emacs-build-system)
+ (home-page "http://github.com/k-talo/volatile-highlights.el")
+ (synopsis "Minor mode for visual feedback on editing operations")
+ (description "This package provides minor mode
+@command{volatile-highlights-mode}, which brings visual feedback to some
+operations by highlighting portions relating to the operations. All of
+highlights made by this library will be removed when any new operation is
+executed.")
+ (license license:gpl3+))))
+
(define-public emacs-global-tags
(let ((commit "06db25d91cc8bfb5e24e02adc04de1226c7e742d")
(revision "0"))
base-commit: 4396fef04717eebb061b2c808087ca638f87a826
prerequisite-patch-id: f9b70f258e65f9418fc5badcb84116c11f514e26
--
2.34.0