From fb743618ec80b0b73b951ebc27cf8b0207be4d8d Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@debian.org>
Date: Tue, 5 Feb 2019 04:14:23 +0000
Subject: [PATCH 3/3] gnu: python-trezor: Update to 0.11.1.
* gnu/packages/finance.scm (python-trezor): Update to 0.11.1.
[arguments]: Remove obsolete slow_cosi test.
Delete test_tx_api test, which requires network access.
[propagated-inputs]: Add python-construct and python-typing-extensions,
Remove python-hidapi, python-protobuf and python-typing.
[native-inputs]: Remove python-mock, Add protobuf, python-black,
python-protobuf and python-isort.
---
gnu/packages/finance.scm | 20 +++++++++++---------
1 file changed, 11 insertions(+), 9 deletions(-)
@@ -679,14 +679,14 @@ Ledger Blue/Nano S.")
(define-public python-trezor
(package
(name "python-trezor")
- (version "0.10.2")
+ (version "0.11.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trezor" version))
(sha256
(base32
- "138k6zsqqpb46k3rcpyslm9q7yq5i6k4myvr9n425jnkadf4vfjd"))))
+ "064yds8f4px0c6grkkanpdjx022g4q87ihzhkmdv9qanv0hz6hv0"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -694,21 +694,23 @@ Ledger Blue/Nano S.")
;; Default tests run device-specific tests which fail, only run specific tests.
(replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
- (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests")
- (invoke "python" "-m" "pytest" "-m" "slow_cosi" "--pyarg" "trezorlib.tests.unit_tests")
- )))))
+ ;; Delete tests that require network access.
+ (delete-file "trezorlib/tests/unit_tests/test_tx_api.py")
+ (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests"))))))
(propagated-inputs
`(("python-click" ,python-click)
+ ("python-construct" ,python-construct)
("python-ecdsa" ,python-ecdsa)
- ("python-hidapi" ,python-hidapi)
("python-libusb1" ,python-libusb1)
("python-mnemonic" ,python-mnemonic)
- ("python-protobuf" ,python-protobuf)
("python-pyblake2" ,python-pyblake2)
("python-requests" ,python-requests)
- ("python-typing" ,python-typing)))
+ ("python-typing-extensions" ,python-typing-extensions)))
(native-inputs
- `(("python-mock" ,python-mock) ; Tests
+ `(("protobuf" ,protobuf) ; Tests
+ ("python-black" ,python-black) ; Tests
+ ("python-protobuf" ,python-protobuf) ; Tests
+ ("python-isort" ,python-isort) ; Tests
("python-pyqt" ,python-pyqt) ; Tests
("python-pytest" ,python-pytest))) ; Tests
(home-page "https://github.com/trezor/python-trezor")
--
2.20.1