Message ID | 20190103220538.25708-1-mail@cbaines.net |
---|---|
State | Accepted |
Headers | show |
Series | [bug#33969] gnu: postgresql: Build with openssl support. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
LGTM!
Danny Milosavljevic <dannym@scratchpost.org> writes:
> LGTM!
Great, I've pushed this to staging now.
Christopher Baines <mail@cbaines.net> writes: > Danny Milosavljevic <dannym@scratchpost.org> writes: > >> LGTM! > > Great, I've pushed this to staging now. This patch has somehow got lost, maybe I didn't push it properly... anyway, I'll push it to again when that branch appears.
Christopher Baines <mail@cbaines.net> writes: > * gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to > [inputs]: Add openssl. > --- > gnu/packages/databases.scm | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm > index 07c6006c3b..4febd0d915 100644 > --- a/gnu/packages/databases.scm > +++ b/gnu/packages/databases.scm > @@ -814,7 +814,7 @@ as a drop-in replacement of MySQL.") > "0jv26y3f10svrjxzsgqxg956c86b664azyk2wppzpa5x11pjga38")))) > (build-system gnu-build-system) > (arguments > - `(#:configure-flags '("--with-uuid=e2fs") > + `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl") > #:phases > (modify-phases %standard-phases > (add-before 'configure 'patch-/bin/sh > @@ -833,6 +833,7 @@ as a drop-in replacement of MySQL.") > (inputs > `(("readline" ,readline) > ("libuuid" ,util-linux) > + ("openssl" ,openssl) > ("zlib" ,zlib))) > (home-page "https://www.postgresql.org/") > (synopsis "Powerful object-relational database system") After sitting for a while in staging, this has now hit master :) So this bug can be closed.
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm index 07c6006c3b..4febd0d915 100644 --- a/gnu/packages/databases.scm +++ b/gnu/packages/databases.scm @@ -814,7 +814,7 @@ as a drop-in replacement of MySQL.") "0jv26y3f10svrjxzsgqxg956c86b664azyk2wppzpa5x11pjga38")))) (build-system gnu-build-system) (arguments - `(#:configure-flags '("--with-uuid=e2fs") + `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl") #:phases (modify-phases %standard-phases (add-before 'configure 'patch-/bin/sh @@ -833,6 +833,7 @@ as a drop-in replacement of MySQL.") (inputs `(("readline" ,readline) ("libuuid" ,util-linux) + ("openssl" ,openssl) ("zlib" ,zlib))) (home-page "https://www.postgresql.org/") (synopsis "Powerful object-relational database system")